diff mbox series

[bug#55931] gnu: java-commons-lang3: Update to 3.12.0

Message ID 87mtehvxb8.fsf@gmail.com
State Accepted
Headers show
Series [bug#55931] gnu: java-commons-lang3: Update to 3.12.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov June 13, 2022, 7:26 a.m. UTC
Hello Julien,

I've added a patch that removes 'junit-bom' from 'pom.xml' and tried to
build 'java-jmh' as you did; it seems that everything now builds without
errors.

Please find the updated patch attached.

- Artyom

Comments

Julien Lepiller June 13, 2022, 8:50 p.m. UTC | #1
Le Mon, 13 Jun 2022 10:26:19 +0300,
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> a écrit :

> Hello Julien,
> 
> I've added a patch that removes 'junit-bom' from 'pom.xml' and tried
> to build 'java-jmh' as you did; it seems that everything now builds
> without errors.
> 
> Please find the updated patch attached.
> 
> - Artyom

Great! Pushed to master as 4ff9f1689d0d8f3c7555c472ce67aaa928af564d.

Before pushing, I applied a few changes. First, when you add a patch,
don't forget to add it to gnu/local.mk. This ensures "make dist" will
generate a complete tarball. Otherwise, the tarball won't contain the
patch. Second, I added a short comment in the patch to explain its
purpose. Finally, I slightly reworded the changelog text about the
patch, in the commit message.

Thanks!
diff mbox series

Patch

From 39c8cc2a9e057e606cb21dea2584794f8f1d2bec Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 12 Jun 2022 22:34:28 +0300
Subject: [PATCH] gnu: java-commons-lang3: Update to 3.12.0

* gnu/packages/java.scm (java-commons-lang3): Update to 3.12.0.
* gnu/packages/patches/java-commons-lang-fix-dependency.patch: Add to the
  repository.
---
 gnu/packages/java.scm                         |  7 ++--
 .../java-commons-lang-fix-dependency.patch    | 35 +++++++++++++++++++
 2 files changed, 40 insertions(+), 2 deletions(-)
 create mode 100644 gnu/packages/patches/java-commons-lang-fix-dependency.patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index fcac0c2367..d2fbf840a0 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Mike Gerwitz <mtg@gnu.org>
 ;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6206,14 +6207,16 @@  included:
 (define-public java-commons-lang3
   (package
     (name "java-commons-lang3")
-    (version "3.9")
+    (version "3.12.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://apache/commons/lang/source/"
                            "commons-lang3-" version "-src.tar.gz"))
        (sha256
-        (base32 "0s4ffbvsyl16c90l45ximsg4dwd8hmz7wsza3p308fw43h6mwhb6"))))
+        (base32 "09dcv1pkdx3hpf06py8p9511f1wkin6jpacdll0c8vxpbi3yfwzv"))
+       (patches
+        (search-patches "java-commons-lang-fix-dependency.patch"))))
     (build-system ant-build-system)
     (arguments
      `(#:jar-name "commons-lang3.jar"
diff --git a/gnu/packages/patches/java-commons-lang-fix-dependency.patch b/gnu/packages/patches/java-commons-lang-fix-dependency.patch
new file mode 100644
index 0000000000..50e0e94c6b
--- /dev/null
+++ b/gnu/packages/patches/java-commons-lang-fix-dependency.patch
@@ -0,0 +1,35 @@ 
+From 5c15b04ff9d05235460ea58f303fcf3502a943f2 Mon Sep 17 00:00:00 2001
+From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
+Date: Mon, 13 Jun 2022 09:25:42 +0300
+Subject: [PATCH] pom.xml: Remove dependency on 'junit-bom'
+
+---
+ pom.xml | 12 ------------
+ 1 file changed, 12 deletions(-)
+
+diff --git a/pom.xml b/pom.xml
+index 167a85a47..6cd9be57b 100644
+--- a/pom.xml
++++ b/pom.xml
+@@ -513,18 +513,6 @@
+     </contributor>
+   </contributors>
+ 
+-  <dependencyManagement>
+-    <dependencies>
+-      <dependency>
+-        <groupId>org.junit</groupId>
+-        <artifactId>junit-bom</artifactId>
+-        <version>5.7.1</version>
+-        <type>pom</type>
+-        <scope>import</scope>
+-      </dependency>
+-    </dependencies>
+-  </dependencyManagement>
+-
+   <!-- Lang should depend on very little -->
+   <dependencies>
+     <!-- testing -->
+-- 
+2.25.1
+
-- 
2.25.1