diff mbox series

[bug#55563] gnu: Add python-catalogue

Message ID 87y1yufx06.fsf@gmail.com
State Accepted
Headers show
Series [bug#55563] gnu: Add python-catalogue | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov May 21, 2022, 8:31 p.m. UTC
Hello,

this patch adds a Python module "catalogue"[1] under the name
"python-catalogue".

- Artyom

References:
1. "Super lightweight function registries for your library"
   https://pypi.org/project/catalogue/

Comments

Ludovic Courtès May 27, 2022, 9:14 p.m. UTC | #1
Hi,

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

> From b45d368c1644497eca3f65daaec219421d48c9eb Mon Sep 17 00:00:00 2001
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> Date: Sat, 21 May 2022 23:27:59 +0300
> Subject: [PATCH] gnu: Add python-catalogue
>
> * gnu/packages/python-xyz.scm (python-catalogue): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From b45d368c1644497eca3f65daaec219421d48c9eb Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 21 May 2022 23:27:59 +0300
Subject: [PATCH] gnu: Add python-catalogue

* gnu/packages/python-xyz.scm (python-catalogue): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3c4fa16d16..a56b5ef255 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31449,3 +31449,29 @@  written in C.")
     (synopsis "Cython bindings for MurmurHash2")
     (description "This package provides Cython bindings for MurmurHash2.")
     (license license:expat)))
+
+(define-public python-catalogue
+  (package
+    (name "python-catalogue")
+    (version "2.0.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "catalogue" version))
+              (sha256
+               (base32
+                "0srdxiil2xys8q1gpc1nvzhvis3a33d8a7amk2i1rlpbg6p36pak"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest))
+    (inputs (list python python-zipp python-typing-extensions python-mypy))
+    (home-page "https://github.com/explosion/catalogue")
+    (synopsis "Lightweight function registries for your library")
+    (description
+     "\"catalogue\" is a tiny, zero-dependencies library that
+makes it easy to add function (or object) registries to your code.  Function
+registries are helpful when you have objects that need to be both easily
+serializable and fully customizable.  Instead of passing a function into your
+object, you pass in an identifier name, which the object can use to lookup the
+function from the registry.  This makes the object easy to serialize, because the
+name is a simple string.  If you instead saved the function, you'd have to use
+Pickle for serialization, which has many drawbacks.")
+    (license license:expat)))
-- 
2.25.1