diff mbox series

[bug#55517] Acknowledgement ([PATCH]: gnu: emacs-magit: Drop the libgit backend.)

Message ID 86leuw507n.fsf@163.com
State Accepted
Headers show
Series [bug#55517] Acknowledgement ([PATCH]: gnu: emacs-magit: Drop the libgit backend.) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Zhu Zihao May 20, 2022, 3:52 a.m. UTC

Comments

Liliana Marie Prikler May 20, 2022, 6:04 a.m. UTC | #1
Am Freitag, dem 20.05.2022 um 11:52 +0800 schrieb Zhu Zihao:
> -     `(#:emacs ,emacs-no-x             ;module support is required

> +     (list
> +      #:emacs emacs-no-x
You do drop that argument in the second commit, but I think we ought to
still keep the comment in this one.  Do add a space between ';' and
"module", though.

> gnu: emacs-magit: Drop the libgit backend.
> 
> Drop the libgit backend for following reasons:
> 
> 1. The libgit backend of Magitis very incomplete. There's almost no
> benefits, but extra maintenance efforts.
> 
> 2. The libgit backend of Magit can be considered as an extra package.
> And it's still in Proof-Of-Concept status so its quaility doesn't
> satisfy the requirement of Guix package.
I'd rather write this as follows:

> gnu: emacs-magit: Drop the libgit backend.
> 
> The libgit backend currently provides next to no features, but
> demands extra maintenance overhead.  It is in fact not a usable
> backend; thus let's not use it.

The "extra package" thing is imho not so correct from observing the
Makefile (even if there's an extra -pkg.el), so let's wait until
upstream makes that clearer.

Other than that LGTM.
diff mbox series

Patch

From 983a23d9ae1fde345e9ad92f49dbb30e73cc8498 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Fri, 20 May 2022 11:51:02 +0800
Subject: [PATCH 2/2] gnu: emacs-magit: Drop the libgit backend.

Drop the libgit backend for following reasons:

1. The libgit backend of Magitis very incomplete. There's almost no benefits,
but extra maintenance efforts.

2. The libgit backend of Magit can be considered as an extra package. And it's
still in Proof-Of-Concept status so its quaility doesn't satisfy the
requirement of Guix package.

* gnu/packages/emacs-xyz.scm (emacs-magit)[arguments]
<emacs>: Remove this argument.
<exclude>: Exclude the magit-libgit.el and magit-libgit-pkg.el.

[inputs]: Remove emacs-libgit.
---
 gnu/packages/emacs-xyz.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8198638c13..d3ca00475e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -870,9 +870,11 @@  (define-public emacs-magit
     (build-system emacs-build-system)
     (arguments
      (list
-      #:emacs emacs-no-x
       #:tests? #t
       #:test-command #~(list "make" "test")
+      #:exclude #~(cons* "magit-libgit.el"
+                         "magit-libgit-pkg.el"
+                         %default-exclude)
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'build-info-manual
@@ -920,7 +922,7 @@  (define-public emacs-magit
     (inputs
      (list git perl))
     (propagated-inputs
-     (list emacs-dash emacs-libgit emacs-transient emacs-with-editor))
+     (list emacs-dash emacs-transient emacs-with-editor))
     (home-page "https://magit.vc/")
     (synopsis "Emacs interface for the Git version control system")
     (description
-- 
2.36.0