diff mbox series

[bug#55438] doc: Use the shell dollar substitution.

Message ID 20220515223125.128354-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#55438] doc: Use the shell dollar substitution. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 15, 2022, 10:31 p.m. UTC
Follow up of beaf701d65e9f94d0539e705d6f58a65313c5655.

* doc/guix.texi: Replace the shell backquote deprecated substitution by the
dollar one.
---
 doc/guix.texi | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: ebb43029506d994bee0c2b890881fd61a0b0c202

Comments

Maxim Cournoyer May 18, 2022, 4:41 a.m. UTC | #1
Hi Simon!

zimoun <zimon.toutoune@gmail.com> writes:

> Follow up of beaf701d65e9f94d0539e705d6f58a65313c5655.
>
> * doc/guix.texi: Replace the shell backquote deprecated substitution by the
> dollar one.

I'm nitpicking, but per "info bash", I'd reword the commit summary as
"Use new-style command substitution".  And "Replace the shell old-style
command substitution with the new-style one."

With this, I'd be happy to push :-)

Thanks!

Maxim
Julien Lepiller June 5, 2022, 11:40 a.m. UTC | #2
Le Wed, 18 May 2022 00:41:03 -0400,
Maxim Cournoyer <maxim.cournoyer@gmail.com> a écrit :

> Hi Simon!
> 
> zimoun <zimon.toutoune@gmail.com> writes:
> 
> > Follow up of beaf701d65e9f94d0539e705d6f58a65313c5655.
> >
> > * doc/guix.texi: Replace the shell backquote deprecated
> > substitution by the dollar one.  
> 
> I'm nitpicking, but per "info bash", I'd reword the commit summary as
> "Use new-style command substitution".  And "Replace the shell
> old-style command substitution with the new-style one."
> 
> With this, I'd be happy to push :-)
> 
> Thanks!
> 
> Maxim
> 
> 
> 

I talked with Simon who agreed with the change, so pushed to master as
e584e58e925ca9423b46f636f08ad87c8d12a229, thanks!
diff mbox series

Patch

diff --git a/doc/guix.texi b/doc/guix.texi
index e1fb50a634..c162d3a79d 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -3451,7 +3451,7 @@  The typical use case is to define these environment variables in the
 shell:
 
 @example
-$ eval `guix package --search-paths`
+$ eval $(guix package --search-paths)
 @end example
 
 @var{kind} may be one of @code{exact}, @code{prefix}, or @code{suffix},