diff mbox series

[bug#55482] gnu: botan: Update to 2.19.1.

Message ID 20220517140512.1713-1-jackhill@jackhill.us
State Accepted
Headers show
Series [bug#55482] gnu: botan: Update to 2.19.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jack Hill May 17, 2022, 2:05 p.m. UTC
* gnu/packages/crypto.scm (botan): Update to 2.19.1.
---
 gnu/packages/crypto.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

I tested this change by building Botan's two dependent packages on
x86_64 Linux, and everything looked good.

Comments

Maxim Cournoyer May 17, 2022, 9:08 p.m. UTC | #1
Hi Jack,

Jack Hill <jackhill@jackhill.us> writes:

> * gnu/packages/crypto.scm (botan): Update to 2.19.1.
> ---
>  gnu/packages/crypto.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> I tested this change by building Botan's two dependent packages on
> x86_64 Linux, and everything looked good.
>
> diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
> index f938d3c115..25aa745b7e 100644
> --- a/gnu/packages/crypto.scm
> +++ b/gnu/packages/crypto.scm
> @@ -946,14 +946,14 @@ (define-public rhash
>  (define-public botan
>    (package
>      (name "botan")
> -    (version "2.18.2")
> +    (version "2.19.1")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "https://botan.randombit.net/releases/"
>                                    "Botan-" version ".tar.xz"))
>                (sha256
>                 (base32
> -                "0zih8agygp39ff0dwi3fv8y7dnnzpz3y86kcgjbhzlxry49kn6jl"))))
> +                "0q2mzzg0a40prp9gwjk7d9fn8kwj6z2x6h6mzlm0hr6sxz7h0vp2"))))
>      (build-system gnu-build-system)
>      (arguments
>       '(#:phases

Applied as 423a3a6b6a, thanks!

Maxim
Jack Hill May 17, 2022, 9:12 p.m. UTC | #2
On Tue, 17 May 2022, Maxim Cournoyer wrote:

> Applied as 423a3a6b6a, thanks!

Awesome, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index f938d3c115..25aa745b7e 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -946,14 +946,14 @@  (define-public rhash
 (define-public botan
   (package
     (name "botan")
-    (version "2.18.2")
+    (version "2.19.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://botan.randombit.net/releases/"
                                   "Botan-" version ".tar.xz"))
               (sha256
                (base32
-                "0zih8agygp39ff0dwi3fv8y7dnnzpz3y86kcgjbhzlxry49kn6jl"))))
+                "0q2mzzg0a40prp9gwjk7d9fn8kwj6z2x6h6mzlm0hr6sxz7h0vp2"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases