diff mbox series

[bug#55485] gnu: wla-dx: Update to 10.1.

Message ID 20220517172445.14740-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#55485] gnu: wla-dx: Update to 10.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber May 17, 2022, 5:24 p.m. UTC
* gnu/packages/assembly.scm (wla-dx): Update to 10.1.
[native-inputs]: Use new style.
---
 gnu/packages/assembly.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

M May 17, 2022, 6:02 p.m. UTC | #1
Felix Gruber schreef op di 17-05-2022 om 17:24 [+0000]:
>       `(#:tests? #f))                    ; no tests

10.1 appears to have lots of tests in
<https://github.com/vhelin/wla-dx/tree/v10.1/tests>.

It looks like you can run them with run_tests.sh:

https://github.com/vhelin/wla-dx/blob/master/run_tests.sh

Greetings,
Maxime.
Felix Gruber May 18, 2022, 5:28 p.m. UTC | #2
Hi Maxime,

On 5/17/22 20:02, Maxime Devos wrote:
> Felix Gruber schreef op di 17-05-2022 om 17:24 [+0000]:
>>        `(#:tests? #f))                    ; no tests
> 
> 10.1 appears to have lots of tests in
> <https://github.com/vhelin/wla-dx/tree/v10.1/tests>.
> 
> It looks like you can run them with run_tests.sh:
> 
> https://github.com/vhelin/wla-dx/blob/master/run_tests.sh

Thanks for the hint. I'll send a new patch that uses this run_tests.sh 
script in its 'check phase.

Kind regards,
Felix
diff mbox series

Patch

diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index b2830716e1..534cffd7df 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -342,7 +342,7 @@  package for the Game Boy and Game Boy Color.  It consists of:
 (define-public wla-dx
   (package
     (name "wla-dx")
-    (version "9.12")
+    (version "10.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -351,10 +351,9 @@  package for the Game Boy and Game Boy Color.  It consists of:
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1wlbqv2rgk9q6m9an1mi0i29250zl8lw7zipki2bbi9mczpyczli"))))
+                "1nh2k2xn5fj389gq68f3fxgrxakgn8c6dw2ffqay86s3706hac9w"))))
     (build-system cmake-build-system)
-    (native-inputs
-     `(("sphinx" ,python-sphinx)))      ; to generate man pages
+    (native-inputs (list python-sphinx)) ; to generate man pages
     (arguments
      `(#:tests? #f))                    ; no tests
     (home-page "https://github.com/vhelin/wla-dx")