diff mbox series

[bug#55262] gnu: mangohud: Update to 0.6.7.

Message ID LmgF8h6Zc7Avsa4cGw7okxg4lfmYSMhF6KWP5gPKSFgZZuLO5uzYXIerqdVhXaBBtN0BHScLhDhrzsxMjN0qYE3nEh5ReCGCUswuycxghgA=@protonmail.com
State Accepted
Headers show
Series [bug#55262] gnu: mangohud: Update to 0.6.7. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias May 4, 2022, 7:41 p.m. UTC
Hello,

Attached is a patch to update mangohud to the latest release. The package is slightly simplified now as a file we had to patch paths for has been removed, along with the now unneeded input (libdrm). I checked that it built successfully and did a quick test with glxgears (but didn't do a Vulkan test).

John

Comments

Mathieu Othacehe May 9, 2022, 8 a.m. UTC | #1
Hello,

> Attached is a patch to update mangohud to the latest release. The package is
> slightly simplified now as a file we had to patch paths for has been removed,
> along with the now unneeded input (libdrm). I checked that it built
> successfully and did a quick test with glxgears (but didn't do a Vulkan test).

Pushed as 7bacea65acc10c16e51c2f78d0bd443206a861e4.

Thanks,

Mathieu
diff mbox series

Patch

From 58b8f648c946a3ab8588f5db6157958f8e7d9d6e Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Wed, 4 May 2022 15:34:09 -0400
Subject: [PATCH] gnu: mangohud: Update to 0.6.7.

* gnu/packages/graphics.scm (mangohud): Update to 0.6.7.
[phases]{patch-paths}: Remove loader_libdrm.cpp path patch as the file has
been removed.
[inputs]: Remove libdrm input, no longer needed.
---
 gnu/packages/graphics.scm | 10 ++--------
 1 file changed, 2 insertions(+), 8 deletions(-)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 2cc75d57cf..9f93205183 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -872,7 +872,7 @@  (define-public alembic
 (define-public mangohud
   (package
     (name "mangohud")
-    (version "0.6.6-1")
+    (version "0.6.7")
     (source
      (origin
        (method git-fetch)
@@ -881,7 +881,7 @@  (define-public mangohud
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0ka004wxkajmvs5vy60r4ckm7f169c61rrd46w6gywkaqf5yp1ab"))))
+        (base32 "0n2x6agv2j8nd6h1998dqsphb7k57zx8vsayv47dqix28kg5kixz"))))
     (build-system meson-build-system)
     (arguments
      (list
@@ -912,11 +912,6 @@  (define-public mangohud
               (substitute* "src/meson.build"
                 (("\\\\\\$LIB")
                  "lib"))
-              (substitute* "src/loaders/loader_libdrm.cpp"
-                (("libdrm.so.2")
-                 (search-input-file inputs "lib/libdrm.so.2"))
-                (("libdrm_amdgpu.so.1")
-                 (search-input-file inputs "lib/libdrm_amdgpu.so.1")))
               (substitute* "src/overlay.cpp"
                 (("glxinfo")
                  (search-input-file inputs "bin/glxinfo")))
@@ -934,7 +929,6 @@  (define-public mangohud
            glslang
            `(,hwdata "pci")
            imgui-1.86
-           libdrm
            libx11
            mesa
            mesa-utils
-- 
2.36.0