diff mbox series

[bug#55176] gnu: nftables: Update to 1.0.2.

Message ID N0lvUJ2--3-2@tutanota.com
State Accepted
Headers show
Series [bug#55176] gnu: nftables: Update to 1.0.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

vasilii.smirnov--- via Guix-patches" via April 28, 2022, 8:47 p.m. UTC
Patch is taken from upstream. https://git.netfilter.org/nftables/patch/?id=18a08fb7f0443f8bde83393bd6f69e23a04246b3

Comments

Ludovic Courtès May 6, 2022, 8:30 a.m. UTC | #1
Hi,

kiasoc5@tutanota.com skribis:

>>From 3a2a524a960cefdaaa2a9351f01fe81b7ab19ef0 Mon Sep 17 00:00:00 2001
> From: kiasoc5 <kiasoc5@tutanota.com>
> Date: Thu, 28 Apr 2022 16:41:10 -0400
> Subject: [PATCH] gnu: nftables: Update to 1.0.2.
>
> * gnu/packages/patches/nftables-fix-makefile.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add it.
> * gnu/packages/linux.scm (nftables): Update to 1.0.2.
> [source]: Add patch.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 3a2a524a960cefdaaa2a9351f01fe81b7ab19ef0 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Thu, 28 Apr 2022 16:41:10 -0400
Subject: [PATCH] gnu: nftables: Update to 1.0.2.

* gnu/packages/patches/nftables-fix-makefile.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/linux.scm (nftables): Update to 1.0.2.
[source]: Add patch.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/linux.scm                        | 21 +++++++++---
 .../patches/nftables-fix-makefile.patch       | 34 +++++++++++++++++++
 3 files changed, 52 insertions(+), 4 deletions(-)
 create mode 100644 gnu/packages/patches/nftables-fix-makefile.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 9bad87710c..4971bf84fa 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1528,6 +1528,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/netsurf-system-utf8proc.patch		\
   %D%/packages/patches/netsurf-y2038-tests.patch		\
   %D%/packages/patches/netsurf-longer-test-timeout.patch	\
+  %D%/packages/patches/nftables-fix-makefile.patch		\
   %D%/packages/patches/nhc98-c-update.patch			\
   %D%/packages/patches/nix-dont-build-html-doc.diff		\
   %D%/packages/patches/nfs4-acl-tools-0.3.7-fixpaths.patch	\
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c67b5922e6..64f192b2ad 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7238,7 +7238,7 @@  (define-public libnftnl/fixed
 (define-public nftables
   (package
     (name "nftables")
-    (version "1.0.1")
+    (version "1.0.2")
     (source
      (origin
        (method url-fetch)
@@ -7247,14 +7247,27 @@  (define-public nftables
                   (string-append "https://www.nftables.org/projects/nftables"
                                  "/files/nftables-" version ".tar.bz2")))
        (sha256
-        (base32 "08x4xw0s5sap3q7jfr91v7mrkxrydi4dvsckw85ims0qb1ibmviw"))))
+        (base32 "00jcjn1pl7qyqpg8pd4yhlkys7wbj4vkzgg73n27nmplzips6a0b"))
+       (patches
+        (search-patches "nftables-fix-makefile.patch"))))
     (build-system gnu-build-system)
     (arguments `(#:configure-flags
                  '("--disable-static"
                    "--with-cli=readline"
-                   "--with-json")))
+                   "--with-json")
+                 #:phases
+                  (modify-phases %standard-phases
+                    (add-before 'configure 'autoreconf
+                      (lambda _
+                        (invoke "autoreconf" "-fi"))))))
     (inputs (list gmp libmnl libnftnl readline jansson))
-    (native-inputs (list pkg-config bison flex docbook2x))
+    (native-inputs (list pkg-config
+                         bison
+                         flex
+                         docbook2x
+                         autoconf
+                         automake
+                         libtool))
     (home-page "https://www.nftables.org")
     (synopsis "Userspace utility for Linux packet filtering")
     (description "nftables is the project that aims to replace the existing
diff --git a/gnu/packages/patches/nftables-fix-makefile.patch b/gnu/packages/patches/nftables-fix-makefile.patch
new file mode 100644
index 0000000000..1660635874
--- /dev/null
+++ b/gnu/packages/patches/nftables-fix-makefile.patch
@@ -0,0 +1,34 @@ 
+From 18a08fb7f0443f8bde83393bd6f69e23a04246b3 Mon Sep 17 00:00:00 2001
+From: Pablo Neira Ayuso <pablo@netfilter.org>
+Date: Tue, 22 Feb 2022 00:56:36 +0100
+Subject: examples: compile with `make check' and add AM_CPPFLAGS
+
+Compile examples via `make check' like libnftnl does. Use AM_CPPFLAGS to
+specify local headers via -I.
+
+Unfortunately, `make distcheck' did not catch this compile time error in
+my system, since it was using the nftables/libnftables.h file of the
+previous nftables release.
+
+Fixes: 5b364657a35f ("build: missing SUBIRS update")
+Fixes: caf2a6ad2d22 ("examples: add libnftables example program")
+Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
+---
+ examples/Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index c972170d..3b8b0b67 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -1,4 +1,6 @@
+-noinst_PROGRAMS	= nft-buffer		\
++check_PROGRAMS	= nft-buffer		\
+ 		  nft-json-file
+ 
++AM_CPPFLAGS = -I$(top_srcdir)/include
++
+ LDADD = $(top_builddir)/src/libnftables.la
+-- 
+cgit v1.2.3
+

base-commit: 882cacc1bb5be0df334dd7ce55b385a3a1678728
-- 
2.36.0