diff mbox series

[bug#55083,1/2] gnu: add python-librouteros

Message ID 20220423164428.28465-1-GNUtoo@cyberdimension.org
State New
Headers show
Series [bug#55083,1/2] gnu: add python-librouteros | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Denis 'GNUtoo' Carikli April 23, 2022, 4:44 p.m. UTC
* gnu/packages/python-xyz.scm (python-librouteros): New variable

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
 gnu/packages/python-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

M April 23, 2022, 6:45 p.m. UTC | #1
Denis 'GNUtoo' Carikli schreef op za 23-04-2022 om 18:44 [+0200]:
> * gnu/packages/python-xyz.scm (python-librouteros): New variable
> 
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>

While this is a thing for, say, the Linux kernel, Guix does not have a
DCO and this is not what Signed-off-by means in Guix.  From the Guix
manual:

   When pushing a commit on behalf of somebody else, please add a
‘Signed-off-by’ line at the end of the commit log message—e.g., with
‘git am --signoff’.  This improves tracking of who did what.

Greetings,
Maxime.
M April 23, 2022, 6:45 p.m. UTC | #2
Denis 'GNUtoo' Carikli schreef op za 23-04-2022 om 18:44 [+0200]:
> +    (synopsis "Python implementation of MikroTik RouterOS API")
> +    (description "Python implementation of MikroTik RouterOS API")

A description is missing here (it's identical to the synopsis)
M April 23, 2022, 6:48 p.m. UTC | #3
Denis 'GNUtoo' Carikli schreef op za 23-04-2022 om 18:44 [+0200]:
> +    (license license:gpl2)))

GPL-2-only can easily cause compatibility issues, would upstream be
amenable to making it GPL-2-or-later, or (alternatively) just GPL-2-or-
3-at-your-choice?

Greetings,
Maxime.
Denis 'GNUtoo' Carikli Oct. 29, 2022, 11:30 a.m. UTC | #4
Hi,

In the bug report about licensing it was unclear if
python-librouteros was GPLv2 only[1] or GPLv2 or later[2].

The comments were by the same person (the project owner in github) and
the one stating that it is GPLv2 or later came after the one stating
that it is GPLv2 only.

Bundlewrap considered it as GPLv2 of that later comment[3].

So to get a definitive clarification I send a patch to librouteros
for the license clarification[4] and it was accepted.

So I can now cleanup the code, update the packages to the latest
versions if necessary and get all that merged.

Do I need to use the exact commit with the license clarification or can
I use the latest release? Or do I backport that commit?

Since it's a license clarification and not a license change, I guess
that it works retrospectively too.

References:
-----------
[1]https://github.com/luqasz/librouteros/issues/129#issuecomment-1111537090
[2]https://github.com/luqasz/librouteros/issues/129#issuecomment-1136123888
[3]https://github.com/bundlewrap/bundlewrap/issues/709#issuecomment-1249674037
[4]https://github.com/luqasz/librouteros/commit/bbf0e580ac03b818190d2a3839046dc7e1a06a90

Denis.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a5d311680..8d6b91c8f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -119,6 +119,7 @@ 
 ;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
 ;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12347,6 +12348,22 @@  (define-public python-idna
 (define-public python2-idna
   (package-with-python2 python-idna))
 
+(define-public python-librouteros
+  (package
+    (name "python-librouteros")
+    (version "3.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "librouteros" version))
+              (sha256
+               (base32
+                "121z8w47sx9hczg0jhxwsy2ld1r52z9nnyxqzljb4vfphi0gkh78"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/luqasz/librouteros")
+    (synopsis "Python implementation of MikroTik RouterOS API")
+    (description "Python implementation of MikroTik RouterOS API")
+    (license license:gpl2)))
+
 (define-public python-libsass
   (package
     (name "python-libsass")