diff mbox series

[bug#54836,2/3] http-client: Fix redirection.

Message ID 20220410134114.371-2-attila@lendvai.name
State New
Headers show
Series [bug#54836,v2,1/3] http-client: Added accept-all-response-codes? argument. | expand

Commit Message

Attila Lendvai April 10, 2022, 1:41 p.m. UTC
* guix/http-client.scm (http-fetch): Use the right uri variable in case of
redirection.
---
 guix/http-client.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès April 11, 2022, 12:44 p.m. UTC | #1
Hi,

Attila Lendvai <attila@lendvai.name> skribis:

> * guix/http-client.scm (http-fetch): Use the right uri variable in case of
> redirection.
> ---
>  guix/http-client.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/guix/http-client.scm b/guix/http-client.scm
> index 8a5b3deecd..b8689a22ed 100644
> --- a/guix/http-client.scm
> +++ b/guix/http-client.scm
> @@ -148,7 +148,7 @@ (define uri*
>                              (or (not (uri-host uri))
>                                  (string=? host (uri-host uri)))
>                              port)
> -                       (open-connection uri*
> +                       (open-connection uri

Good catch!  This fixes <https://issues.guix.gnu.org/54609>.

Applied.

Ludo’.
diff mbox series

Patch

diff --git a/guix/http-client.scm b/guix/http-client.scm
index 8a5b3deecd..b8689a22ed 100644
--- a/guix/http-client.scm
+++ b/guix/http-client.scm
@@ -148,7 +148,7 @@  (define uri*
                             (or (not (uri-host uri))
                                 (string=? host (uri-host uri)))
                             port)
-                       (open-connection uri*
+                       (open-connection uri
                                         #:verify-certificate?
                                         verify-certificate?
                                         #:timeout timeout)))))