diff mbox series

[bug#54847] gnu: Add hyfetch.

Message ID DM5PR04MB3772DF84EE4FBE0F567E6AC299EA9@DM5PR04MB3772.namprd04.prod.outlook.com
State Accepted
Headers show
Series [bug#54847] gnu: Add hyfetch. | expand

Commit Message

Wamm K. D April 11, 2022, 8:01 a.m. UTC
---
 gnu/packages/admin.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

M April 11, 2022, 9:02 a.m. UTC | #1
Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> +    (propagated-inputs (list python-hypy-utils python-typing-extensions))

Do these need to be propagated?

Greetings,
Maxime
M April 11, 2022, 9:04 a.m. UTC | #2
Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> +    (arguments `(#:phases (modify-phases %standard-phases
> +                            (add-before 'build 'set-HOME
> +                              (lambda _  ;; Tries to set files in .config
> +                                (setenv "HOME" "/tmp"))))))

neofetch has #:tests? #false, #:make-flags and no set-home phase.  How
come this fork doesn't?

Greetings,
Maxime.
M April 11, 2022, 9:06 a.m. UTC | #3
Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> +    (synopsis "@code{neofetch} with pride flags <3")

You are not restricted to ASCII, you can write 🫀, 💓, 💔, 💕, 💖, 💗,
💘, 💙, 💚, 💛, 💜, 💝 or 💞 instead of <3.

Greetings,
Maxime.
M April 11, 2022, 9:06 a.m. UTC | #4
Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> +    (synopsis "@code{neofetch} with pride flags <3")

What does <3 mean here?

Greetings,
Maxime.
M April 11, 2022, 9:08 a.m. UTC | #5
Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> any ASCII file of your choice

Is it restricted to the ASCII character set, or does any text file do
and can I put 🫀 in the file as well?

Greetings,
Maxime.
M April 11, 2022, 9:11 a.m. UTC | #6
Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> +    (home-page "https://github.com/hykilpikonna/HyFetch")

It's a fork.  Is there some web page tracking upstreaming progress?
E.g., neofetch could suppport multiple modes, the default 'neofetch'
when running the 'bin/neofetch' binary, 'hyfetch' when running
'bin/hyfetch', etc.

Greetings,
Maxime.
Wamm K. D April 11, 2022, 5:07 p.m. UTC | #7
> On Monday, April 11, 2022, 04:02:59 AM CDT, Maxime Devos <maximedevos@telenet.be> wrote:
>
> Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> > +    (propagated-inputs (list python-hypy-utils python-typing-extensions))
>
> Do these need to be propagated?

Fair question; that was just what ~guix import pypi hyfetch --recursive~ had given me but I tried it out, again, with them just as ~inputs~ and it worked just fine so I'll get that adjusted.


> Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> > +    (arguments `(#:phases (modify-phases %standard-phases
> > +                            (add-before 'build 'set-HOME
> > +                              (lambda _  ;; Tries to set files in .config
> > +                                (setenv "HOME" "/tmp"))))))
>
> neofetch has #:tests? #false, #:make-flags and no set-home phase.  How
> come this fork doesn't?

If I were to hazard a guess, because this is a Python package/module while the other is built with ~make~? I'm afraid I don't know enough to say, otherwise; I can say that the package was able to build alright and run fine without disabling tests.


> Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> > +    (synopsis "@code{neofetch} with pride flags <3")
>
> You are not restricted to ASCII, you can write 🫀, 💓, 💔, 💕, 💖, 💗,
> 💘, 💙, 💚, 💛, 💜, 💝 or 💞 instead of <3.
 >
> What does <3 mean here?

Neat; I didn't know that so thanks for the heads up. I think it's just a heart, to be affectionate; it's the synopsis given for the module on pypi.org and, so, was pulled in by the import. I always try to stick as much as possible to the creator's words for their own software so I just left it in but it's definitely far from mandatory in describing what it is the package does. I can remove it, if you'd like, or swap the ASCII representation to one of the emojis you suggested, if that might make it less ambiguous.


> Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> > any ASCII file of your choice
>
> Is it restricted to the ASCII character set, or does any text file do
> and can I put 🫀 in the file as well?

Ummm, another really good question. I was assuming, as its a fork of =neofetch=, that the same rules would apply and, so, just borrowed from the =neofetch= description, but, checking this out, I'm not sure if =hyfetch= has this functionality. I'll remove it from there when I update the ~inputs~.


> Wamm K. D schreef op ma 11-04-2022 om 03:01 [-0500]:
> > +    (home-page "https://github.com/hykilpikonna/HyFetch")
>
> It's a fork.  Is there some web page tracking upstreaming progress?
> E.g., neofetch could suppport multiple modes, the default 'neofetch'
> when running the 'bin/neofetch' binary, 'hyfetch' when running
> 'bin/hyfetch', etc.
>
> Greetings,
>
> Maxime.

Outside of the GitHub page itself, not that I know of. I'd probably need a bit more guidance on how to set something like this up, though. That being said, the build process between the two may be more different than similar as =hyfetch= is using Python while =neofetch= is just using a plain Makefile; the old Makefile for =neofetch= is still in the repo., unaltered, so I'm not sure how much direct overlap with the original code still exists, for =hyfetch=. I'm not sure how much of a difference any of that makes but thought I'd, at least, make note.
Ludovic Courtès April 19, 2022, 10:04 a.m. UTC | #8
Hi Jaft,

Could you send updating patches, updating some of the suggestions
Maxime made?

Thanks in advance!

Ludo’.
Wamm K. D April 19, 2022, 6:36 p.m. UTC | #9
Sure thing! There were some threads that Maxime had inquired about that I thought he might provide further guidance on since I wasn't sure how he'd want to proceed with them but I'll get together the changes we have agree upon, so far, and send out an updated patch with them, later today.






> On Tuesday, April 19, 2022, 05:04:47 AM CDT, Ludovic Courtès <ludo@gnu.org> wrote: 
>
>
>
>
>
> Hi Jaft,
>
> Could you send updating patches, updating some of the suggestions
> Maxime made?
>
> Thanks in advance!
>
> Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 1db04adf71..e15d443771 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -47,6 +47,7 @@ 
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3713,6 +3714,33 @@  (define-public neofetch
 you are running, what theme or icon set you are using, etc.")
     (license license:expat)))
 
+(define-public hyfetch
+  (package
+    (name "hyfetch")
+    (version "1.0.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "HyFetch" version))
+        (sha256
+          (base32 "1bfkycdhsyzkk6q24gdy1xwvyz0rvkr7xk2khbn74b3nk6kp83r2"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-hypy-utils python-typing-extensions))
+    (arguments `(#:phases (modify-phases %standard-phases
+                            (add-before 'build 'set-HOME
+                              (lambda _  ;; Tries to set files in .config
+                                (setenv "HOME" "/tmp"))))))
+    (home-page "https://github.com/hykilpikonna/HyFetch")
+    (synopsis "@code{neofetch} with pride flags <3")
+    (description "HyFetch is a command-line system information tool fork of
+@code{neofetch}.  HyFetch displays information about your system next to an
+image, your OS logo, or any ASCII file of your choice.  The ASCII representation
+is then colored in the pattern of the pride flag of your choice.  The main
+purpose of HyFetch is to be used in screenshots to show other users what
+operating system or distribution you are running, what theme or icon set you are
+using, etc.")
+    (license license:expat)))
+
 (define-public screenfetch
   (package
     (name "screenfetch")