diff mbox series

[bug#54700] gnu: strawberry: Update to 1.0.3.

Message ID 20220403202131.9742-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#54700] gnu: strawberry: Update to 1.0.3. | expand

Commit Message

Michael Rohleder April 3, 2022, 8:21 p.m. UTC
* gnu/packages/music.scm (strawberry): Update to 1.0.3.
---
 gnu/packages/music.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Brendan Tildesley April 5, 2022, 4:47 a.m. UTC | #1
It does not compile for me.


In file included from 
/tmp/guix-build-strawberry-1.0.3.drv-0/source/src/core/mergedproxymodel.cpp:40:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp: 
In member function 
‘boost::multi_index::detail::hashed_index<KeyFromValue, Hash, Pred, 
SuperMeta, TagList, Category>::iterator 
boost::multi_index::detail::hashed_index<KeyFromValue, Hash, Pred, 
SuperMeta, TagList, Category>::find(const CompatibleKey&, const 
CompatibleHash&, const CompatiblePred&) const’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:542:17: 
error: ‘promotes_1st_arg’ was not declared in this scope
   542 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
       |                 ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:542:48: 
error: expected primary-expression before ‘,’ token
   542 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
       |                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:542:62: 
error: expected primary-expression before ‘,’ token
   542 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
|                                                              ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:542:71: 
error: expected primary-expression before ‘>’ token
   542 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:542:73: 
error: expected primary-expression before ‘)’ token
   542 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp: 
In member function 
‘boost::multi_index::detail::hashed_index<KeyFromValue, Hash, Pred, 
SuperMeta, TagList, Category>::size_type 
boost::multi_index::detail::hashed_index<KeyFromValue, Hash, Pred, 
SuperMeta, TagList, Category>::count(const CompatibleKey&, const 
CompatibleHash&, const CompatiblePred&) const’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:559:17: 
error: ‘promotes_1st_arg’ was not declared in this scope
   559 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
       |                 ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:559:48: 
error: expected primary-expression before ‘,’ token
   559 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
       |                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:559:62: 
error: expected primary-expression before ‘,’ token
   559 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
|                                                              ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:559:71: 
error: expected primary-expression before ‘>’ token
   559 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:559:73: 
error: expected primary-expression before ‘)’ token
   559 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp: 
In member function 
‘std::pair<boost::multi_index::detail::hashed_index_iterator<boost::multi_index::detail::hashed_index_node<typename 
SuperMeta::type::index_node_type>, 
boost::multi_index::detail::bucket_array<typename 
SuperMeta::type::final_allocator_type>, Category, 
boost::multi_index::detail::hashed_index_global_iterator_tag>, 
boost::multi_index::detail::hashed_index_iterator<boost::multi_index::detail::hashed_index_node<typename 
SuperMeta::type::index_node_type>, 
boost::multi_index::detail::bucket_array<typename 
SuperMeta::type::final_allocator_type>, Category, 
boost::multi_index::detail::hashed_index_global_iterator_tag> > 
boost::multi_index::detail::hashed_index<KeyFromValue, Hash, Pred, 
SuperMeta, TagList, Category>::equal_range(const CompatibleKey&, const 
CompatibleHash&, const CompatiblePred&) const’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:576:17: 
error: ‘promotes_1st_arg’ was not declared in this scope
   576 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
       |                 ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:576:48: 
error: expected primary-expression before ‘,’ token
   576 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
       |                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:576:62: 
error: expected primary-expression before ‘,’ token
   576 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
|                                                              ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:576:71: 
error: expected primary-expression before ‘>’ token
   576 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:576:73: 
error: expected primary-expression before ‘)’ token
   576 | 
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
In file included from 
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_impl.hpp:65,
                  from 
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/ordered_index.hpp:17,
                  from 
/tmp/guix-build-strawberry-1.0.3.drv-0/source/src/core/mergedproxymodel.cpp:44:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp: 
In function ‘Node* boost::multi_index::detail::ordered_index_find(Node*, 
Node*, const KeyFromValue&, const CompatibleKey&, const 
CompatibleCompare&)’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:74:7: 
error: ‘promotes_1st_arg’ was not declared in this scope
    74 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>,
       |       ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:74:64: 
error: template argument 1 is invalid
    74 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>,
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:7: 
error: ‘promotes_2nd_arg’ was not declared in this scope
    75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
       |       ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:41: 
error: expected primary-expression before ‘,’ token
    75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
       |                                         ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:50: 
error: expected primary-expression before ‘,’ token
    75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
       |                                                  ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:64: 
error: expected primary-expression before ‘>’ token
    75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:66: 
error: expected primary-expression before ‘>’ token
    75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:68: 
error: expected primary-expression before ‘)’ token
    75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp: 
In function ‘Node* 
boost::multi_index::detail::ordered_index_lower_bound(Node*, Node*, 
const KeyFromValue&, const CompatibleKey&, const CompatibleCompare&)’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:123:5: 
error: ‘promotes_2nd_arg’ was not declared in this scope
   123 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey>());
       |     ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:123:39: 
error: expected primary-expression before ‘,’ token
   123 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey>());
       |                                       ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:123:48: 
error: expected primary-expression before ‘,’ token
   123 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey>());
       |                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:123:62: 
error: expected primary-expression before ‘>’ token
   123 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey>());
|                                                              ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:123:64: 
error: expected primary-expression before ‘)’ token
   123 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey>());
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp: 
In function ‘Node* 
boost::multi_index::detail::ordered_index_upper_bound(Node*, Node*, 
const KeyFromValue&, const CompatibleKey&, const CompatibleCompare&)’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:169:5: 
error: ‘promotes_1st_arg’ was not declared in this scope
   169 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>());
       |     ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:169:39: 
error: expected primary-expression before ‘,’ token
   169 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>());
       |                                       ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:169:53: 
error: expected primary-expression before ‘,’ token
   169 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>());
       |                                                     ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:169:62: 
error: expected primary-expression before ‘>’ token
   169 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>());
|                                                              ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:169:64: 
error: expected primary-expression before ‘)’ token
   169 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>());
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp: 
In function ‘std::pair<Node*, Node*> 
boost::multi_index::detail::ordered_index_equal_range(Node*, Node*, 
const KeyFromValue&, const CompatibleKey&, const CompatibleCompare&)’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:216:7: 
error: ‘promotes_1st_arg’ was not declared in this scope
   216 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>,
       |       ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:216:64: 
error: template argument 1 is invalid
   216 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>,
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:7: 
error: ‘promotes_2nd_arg’ was not declared in this scope
   217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
       |       ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:41: 
error: expected primary-expression before ‘,’ token
   217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
       |                                         ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:50: 
error: expected primary-expression before ‘,’ token
   217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
       |                                                  ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:64: 
error: expected primary-expression before ‘>’ token
   217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:66: 
error: expected primary-expression before ‘>’ token
   217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:68: 
error: expected primary-expression before ‘)’ token
   217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
Michael Rohleder April 5, 2022, 5:12 p.m. UTC | #2
Brendan Tildesley <mail@brendan.scot> writes:
> It does not compile for me.

Weird.  I just build (and run) it successfully (again):
Brendan Tildesley April 8, 2022, 9:59 a.m. UTC | #3
On 6/4/22 03:12, Michael Rohleder wrote:
> Brendan Tildesley <mail@brendan.scot> writes:
>> It does not compile for me.
> Weird.  I just build (and run) it successfully (again):
>
It builds on my desktop but not laptop. not sure what is going on.
Ludovic Courtès April 9, 2022, 10:17 p.m. UTC | #4
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

> * gnu/packages/music.scm (strawberry): Update to 1.0.3.

Applied.  It builds fine for me on top of
0996d48d0e79a360e0d5583b812cd565f62ca32e.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3e3829cefe..89d64957c8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -470,7 +470,7 @@  (define-public clementine
 (define-public strawberry
   (package
     (name "strawberry")
-    (version "1.0.1")
+    (version "1.0.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -479,7 +479,7 @@  (define-public strawberry
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "077dlj0kjcrj4g1h4w8finzykizaar67ik6yng6c8zjp2i5bam1j"))
+                "14fr2bm51k4n5byc9pwh3ba6v15s9jmqxigl1y9h00l7cvmfpbn1"))
               (modules '((guix build utils)
                          (ice-9 regex)))
               (snippet