diff mbox series

[bug#54678] gnu: Add emacs-pyimport.

Message ID 20220402025855.19353-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54678] gnu: Add emacs-pyimport. | expand

Commit Message

jgart April 2, 2022, 2:58 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-pyimport): New variable.

Hi Guixers,

Here is emacs-pyimport.

Also available as a pre-release at https://whereis.みんな/

all best,

jgart
---
 gnu/packages/emacs-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

M April 4, 2022, 6:14 p.m. UTC | #1
jgart via Guix-patches via schreef op vr 01-04-2022 om 22:58 [-0400]:
> +                      (let ((python-pyflakes (assoc-ref inputs "python-pyflakes")))
> +                        (make-file-writable "pyimport.el")
> +                        (substitute* "pyimport.el"
> +                          (("\"pyflakes")
> +                           (string-append "\"" python-pyflakes "/bin/pyflakes")))))))))

Input labels can be avoided here:

  (substitute* ...
    ...
    (string-append ... (search-input-file inputs "bin/pyflakes")))

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bc9a9f1c28..5b17fd9b65 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30828,6 +30828,43 @@  (define-public emacs-org-modern
 headlines, keywords, tables and source blocks.")
    (license license:gpl3+)))
 
+(define-public emacs-pyimport
+  (let ((commit "a6f63cf7ed93f0c0f7c207e6595813966f8852b9")
+        (revision "0"))
+    (package
+      (name "emacs-pyimport")
+      (version (git-version "1.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/Wilfred/pyimport")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1q5gqhvh4zq5dy8vns694warcz48j1hdnxg16sjck4gsi9xivbvs"))))
+      (build-system emacs-build-system)
+      (inputs
+        (list python-pyflakes))
+      (propagated-inputs
+        (list emacs-dash emacs-s emacs-shut-up))
+      (arguments
+        (list #:phases
+              #~(modify-phases %standard-phases
+                  (add-after 'unpack 'patch-pyflakes-executable
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (let ((python-pyflakes (assoc-ref inputs "python-pyflakes")))
+                        (make-file-writable "pyimport.el")
+                        (substitute* "pyimport.el"
+                          (("\"pyflakes")
+                           (string-append "\"" python-pyflakes "/bin/pyflakes")))))))))
+      (home-page "https://github.com/Wilfred/pyimport")
+      (synopsis "Manage Python imports from Emacs")
+      (description
+"@code{emacs-pyimport} manages python imports from Emacs via @code{python-pyflakes}.")
+      (license license:gpl3+)))) ; License is in pyimport.el
+
 (define-public emacs-osm
   (package
     (name "emacs-osm")