diff mbox series

[bug#54284,v2] gnu: Add python-pytest-pudb.

Message ID 20220319015104.17516-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54284,v2] gnu: Add python-pytest-pudb. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart March 19, 2022, 1:51 a.m. UTC
* gnu/packages/check.scm (python-pytest-pudb): New variable.

Hi Ludo,

Thanks for the review. It is much appreciated.

Here's v2.

Let me know if there is anything else to fix. I think I got it all...

all best,

jgart

https://whereis.みんな/
gemini://whereis.みんな/

---
 gnu/packages/check.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Ludovic Courtès March 21, 2022, 1:37 p.m. UTC | #1
Hi jgart,

jgart <jgart@dismail.de> skribis:

> * gnu/packages/check.scm (python-pytest-pudb): New variable.

Perfect.  Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c66ec4722f..335ab7ab11 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3082,6 +3082,41 @@  (define-public python-pytest-dependency
 skipped if any of the dependencies did fail or has been skipped.")
     (license license:asl2.0)))
 
+(define-public python-pytest-pudb
+  ;; PyPi does not include tests
+  (let ((commit "a6b3d2f4d35e558d72bccff472ecde9c9d9c69e5"))
+    (package
+      (name "python-pytest-pudb")
+      ;; Version mentioned in setup.py version field.
+      (version "0.7.0")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/wronglink/pytest-pudb")
+                      (commit commit)))
+                (file-name (git-file-name name commit))
+                (sha256
+                 (base32
+                  "1c0pypxx3y8w7s5bz9iy3w3aablnhn81rnhmb0is8hf2qpm6k3w0"))))
+      (build-system python-build-system)
+      (propagated-inputs (list pudb))
+      (native-inputs (list python-pytest))
+      (arguments
+       `(#:phases (modify-phases %standard-phases
+                    (replace 'check
+                      (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+                        (when tests?
+                          (add-installed-pythonpath inputs outputs)
+                          (invoke "pytest" "-v")))))))
+      (home-page "https://github.com/wronglink/pytest-pudb")
+      (synopsis "Pytest PuDB debugger integration")
+      (description
+       "@code{python-pytest-pudb} provides PuDB debugger integration based
+on pytest PDB integration.  For example, the software developer can
+call pudb by running @code{py.test --pudb} from the command line or by
+including @code{pudb.set_trace} in their test file(s).")
+      (license license:expat))))
+
 (define-public python-pytest-datadir
   (package
     (name "python-pytest-datadir")