diff mbox series

[bug#53926] services: gdm-service-type: Require elogind.

Message ID 20220210202747.27729-1-dev@jpoiret.xyz
State Accepted
Headers show
Series [bug#53926] services: gdm-service-type: Require elogind. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Josselin Poiret Feb. 10, 2022, 8:27 p.m. UTC
* gnu/services/xorg.scm (gdm-shepherd-service): Make it require
elogind.
---
Hello everyone,

GDM needs elogind to function, and up until now it was racing with the
elogind service, leading to dbus trying to start a second elogind
while the first is still setting up.  This should fix it.

Best,
Josselin

 gnu/services/xorg.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès Feb. 10, 2022, 10:18 p.m. UTC | #1
Hi,

Josselin Poiret <dev@jpoiret.xyz> skribis:

> * gnu/services/xorg.scm (gdm-shepherd-service): Make it require
> elogind.
> ---
> Hello everyone,
>
> GDM needs elogind to function, and up until now it was racing with the
> elogind service, leading to dbus trying to start a second elogind
> while the first is still setting up.  This should fix it.

Oh, so that was it…  Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index a5e1a1471d..d6dfb07425 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -975,7 +975,7 @@  (define (gdm-shepherd-service config)
   (list (shepherd-service
          (documentation "Xorg display server (GDM)")
          (provision '(xorg-server))
-         (requirement '(dbus-system user-processes host-name udev))
+         (requirement '(dbus-system user-processes host-name udev elogind))
          (start #~(lambda ()
                     (fork+exec-command
                      (list #$(file-append (gdm-configuration-gdm config)