diff mbox series

[bug#53185,1/3] gnu: Add python-geojson.

Message ID 3EtzkFG7CNAql9uy5cwCklu7UiM3k0skvRz9CAgX0cEdaA_d4OIUzNq59Vyorc1dD0EArvPmoz7Gi-fQLnZ9y6Q1F74qb15BXuf7JS_3I0o=@protonmail.com
State Accepted
Headers show
Series [bug#53185,1/3] gnu: Add python-geojson. | expand

Commit Message

phodina Jan. 11, 2022, 10:45 a.m. UTC
Hi,

this patch series adds command line tool to show weather in your preferred location.

----
Petr

Comments

Ludovic Courtès Jan. 28, 2022, 10:55 p.m. UTC | #1
Hi,

phodina <phodina@protonmail.com> skribis:

> From e7995f7904fa6c51c8ef24e19cd5bb8396abe13d Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Tue, 11 Jan 2022 11:28:57 +0100
> Subject: [PATCH 2/3] gnu: Add python-pyowm.
>
> * gnu/packages/python-web.scm (python-pyowm): New variable.

[...]

> From d3287c48bb665ac08e95b9e65bc21c79c4207894 Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Tue, 11 Jan 2022 11:28:17 +0100
> Subject: [PATCH 1/3] gnu: Add python-geojson.
>
> * gnu/packages/python-xyz.scm (python-geojson): New variable.

[...]

> From 1cb1ea2208e1575b3cdf5539644c9e4e435c0fab Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Tue, 11 Jan 2022 11:29:23 +0100
> Subject: [PATCH 3/3] gnu: Add wfetch.
>
> * gnu/packages/admin.scm (wfetch): New variable.

Applied, after tweaking synopses/descriptions, moving wfetch to
python-xyz.scm (since it has nothing to do with system administration)
and fixing its ‘home-page’.

Please pay attention to these things for subsequent patches and you may
benefit from faster review in return.  :-)

Thanks,
Ludo’.
phodina Jan. 29, 2022, 5:11 a.m. UTC | #2
Thanks Ludo’,

> Hi,
>
> phodina phodina@protonmail.com skribis:
>
> > From e7995f7904fa6c51c8ef24e19cd5bb8396abe13d Mon Sep 17 00:00:00 2001
> >
> > From: Petr Hodina phodina@protonmail.com
> >
> > Date: Tue, 11 Jan 2022 11:28:57 +0100
> >
> > Subject: [PATCH 2/3] gnu: Add python-pyowm.
> >
> > -   gnu/packages/python-web.scm (python-pyowm): New variable.
>
> [...]
>
> > From d3287c48bb665ac08e95b9e65bc21c79c4207894 Mon Sep 17 00:00:00 2001
> >
> > From: Petr Hodina phodina@protonmail.com
> >
> > Date: Tue, 11 Jan 2022 11:28:17 +0100
> >
> > Subject: [PATCH 1/3] gnu: Add python-geojson.
> >
> > -   gnu/packages/python-xyz.scm (python-geojson): New variable.
>
> [...]
>
> > From 1cb1ea2208e1575b3cdf5539644c9e4e435c0fab Mon Sep 17 00:00:00 2001
> >
> > From: Petr Hodina phodina@protonmail.com
> >
> > Date: Tue, 11 Jan 2022 11:29:23 +0100
> >
> > Subject: [PATCH 3/3] gnu: Add wfetch.
> >
> > -   gnu/packages/admin.scm (wfetch): New variable.
>
> Applied, after tweaking synopses/descriptions, moving wfetch to
>
> python-xyz.scm (since it has nothing to do with system administration)
>
> and fixing its ‘home-page’.
>
> Please pay attention to these things for subsequent patches and you may
>
> benefit from faster review in return. :-)
>
> Thanks,
>
> Ludo’.

I've checked the diffs and your synopsis as well as description are more appropriate.

I agree that the package wfetch belongs into python-xyz.scm as it does nothing special. The reason why I placed it in admin.scm was that I found about it due to pfetch and thought it's "smiliar". Then again it does not gather data from the system just fetches some weather info.

Thanks for catching the wrong homepage, as both projects were on github and had the same name it went unnoticed.

I'll be more vigilant next time :-)

----
Petr
diff mbox series

Patch

From 1cb1ea2208e1575b3cdf5539644c9e4e435c0fab Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 11 Jan 2022 11:29:23 +0100
Subject: [PATCH 3/3] gnu: Add wfetch.

* gnu/packages/admin.scm (wfetch): New variable.

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 918a07f014..f64e9f6530 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1859,6 +1859,45 @@  (define-public opendoas
     (license (list license:bsd-3        ; libbsd/*
                    license:isc))))      ; everything else
 
+(define-public wfetch
+  (let ((commit "e1cfa37814aebc9eb56ce994ebe877b6a6f9a715")
+        (revision "1"))
+    (package
+      (name "wfetch")
+      (version (git-version "0.1-pre" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Gcat101/Wfetch")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1dmr85plx8zr6s14ym3r32g6crwxghkval5a24ah90ijx4dbn5q5"))))
+      (build-system python-build-system)
+      (arguments
+       `(#:use-setuptools? #f           ; no setup.py
+         #:tests? #f                    ; no test suite
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'build)
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (bin (string-append out "/bin"))
+                      (share (string-append out "/share")))
+                 (mkdir-p share)
+                 (substitute* "wfetch/wfetch.py"
+                   (("os.sep, 'opt', 'wfetch'") (string-append "'" share "'")))
+                 (install-file "wfetch/wfetch.py" bin)
+                 (copy-recursively "wfetch/icons" share)))))))
+      (inputs (list python-pyowm python-fire python-termcolor python-requests))
+      (home-page "https://github.com/zJairO/wfetch")
+      (synopsis "Neofetch/pfetch, but for weather")
+      (description "This package provides Neofetch/pfetch, but for weather.
+In order to use you must export WEATHER_CLI_API=<your OWM api key>.")
+      (license license:gpl3+))))
+
 (define-public wpa-supplicant-minimal
   (package
     (name "wpa-supplicant-minimal")
-- 
2.34.0