diff mbox series

[bug#53401,01/49] gnu: Add rust-rustc-hex 2.1.0 and 1.0.0.

Message ID 20220120214229.22377-1-attila@lendvai.name
State Accepted
Headers show
Series [bug#53401,01/49] gnu: Add rust-rustc-hex 2.1.0 and 1.0.0. | expand

Commit Message

Attila Lendvai Jan. 20, 2022, 9:41 p.m. UTC
---

this will be a larger series of rust packages that are part of the
dependencies of openethereum. my ultimate goal is to package
openethereum, but it's already so many commits that i'm sending
them ahead as per Ludo's recommendation.

note that i'm not a rust expert, but i tried to make sure that
every package builds fine, and that the order of the commits
matches the order of the dependencies.

the tests are disabled for some packages because they fail. to my
untrained eyes they all looked like incompatibilities (bitrot),
not actual errors.

also note that i have no intuition when/why to use #:skip-build? #t.

 gnu/packages/crates-io.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Attila Lendvai Jan. 24, 2022, 11:43 a.m. UTC | #1
sadly enough this has developed countless merge conflicts.

closing this, and i will open a new one with a single diff.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ffee43e716..b840cb1d2a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46028,6 +46028,39 @@  (define-public rust-rustc-hash-1
      "This package provides a speedy, non-cryptographic hash used in rustc.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-rustc-hex-2
+  (package
+    (name "rust-rustc-hex")
+    (version "2.1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "rustc-hex" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1mkjy2vbn5kzg67wgngwddlk4snmd8mkjkql2dzrzzfh6ajzcx9y"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page "https://github.com/debris/rustc-hex")
+    (synopsis "@code{rustc-serialize} compatible hex conversion traits")
+    (description synopsis)
+    (license (list license:asl2.0 license:expat))))
+
+(define-public rust-rustc-hex-1
+  (package
+    (inherit rust-rustc-hex-2)
+    (name "rust-rustc-hex")
+    (version "1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "rustc-hex" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "07pff94vqc1mhrqp9i06xzayiad4xfx7588zkqsdw875lpkqrsqc"))))))
+
 (define-public rust-rustc-rayon-0.3
   (package
     (name "rust-rustc-rayon")