diff mbox series

[bug#53330] guix: gexp: Export gexp-inputs.

Message ID 20220117225516.21249-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#53330] guix: gexp: Export gexp-inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Jan. 17, 2022, 10:55 p.m. UTC
* guix/gexp.scm (gexp-inputs): Export gexp-inputs variable.
---
 guix/gexp.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

jgart Jan. 17, 2022, 11:19 p.m. UTC | #1
Hi Guixers, wdyt?

gexp-inputs can be a useful function that can be part of the
public interface. Why might this be a good/bad idea?

I can send a patch for gexp-outputs if it makes sense to do so also.

all best,

jgart
jgart Jan. 17, 2022, 11:26 p.m. UTC | #2
On Mon, 17 Jan 2022 18:19:08 -0500 jgart <jgart@dismail.de> wrote:
> Hi Guixers, wdyt?
> 
> gexp-inputs can be a useful function that can be part of the
> public interface. Why might this be a good/bad idea?
> 
> I can send a patch for gexp-outputs if it makes sense to do so also.
> 
> all best,
> 
> jgart

close 53330

‎civodul‎: jgart: i'd rather not expose gexp internals  
‎01/17/2022 | 06:21:27 PM  ‎civodul‎: there's lower-gexp if you really need something low-level
jgart Jan. 18, 2022, 3:12 a.m. UTC | #3
Doxxed!

Thanks!

jgart
diff mbox series

Patch

diff --git a/guix/gexp.scm b/guix/gexp.scm
index 01dca902f7..bdcac652a8 100644
--- a/guix/gexp.scm
+++ b/guix/gexp.scm
@@ -48,6 +48,7 @@  (define-module (guix gexp)
 
             gexp-input
             gexp-input?
+            gexp-inputs
             gexp-input-thing
             gexp-input-output
             gexp-input-native?