diff mbox series

[bug#52700,1/2] gnu: Add python-pydbus.

Message ID b4c7912ed65693643694ab4073757b74060373d3.1640084945.git.avityazev@posteo.org
State Accepted
Headers show
Series gnu: pantalaimon: Propagate python-pydbus and python-notify2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev Dec. 21, 2021, 11:10 a.m. UTC
* gnu/packages/python-xyz (python-pydbus): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Nicolas Goaziou Jan. 16, 2022, 11:21 p.m. UTC | #1
Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

> * gnu/packages/python-xyz (python-pydbus): New variable.

This was applied in 4527743f0a2d58d7cdf5abdd74016908eecd66a6 and
subsequent commit.

Thank you!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2af4794019..35590aece2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -112,6 +112,7 @@ 
 ;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
 ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
 ;;; Copyright © 2021 ZmnSCPxj <ZmnSCPxj@protonmail.com>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8929,6 +8930,26 @@  (define-public python-dbus-next
 mobile environments.")
     (license license:expat)))
 
+(define-public python-pydbus
+  (package
+    (name "python-pydbus")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pydbus" version))
+       (sha256
+        (base32 "0b0gipvz7vcfa9ddmwq2jrx16d4apb0hdnl5q4i3h8jlzwp1c1s2"))))
+    (inputs (list python-pygobject))
+    (build-system python-build-system)
+    (home-page "https://github.com/LEW21/pydbus")
+    (synopsis "Pythonic D-Bus library")
+    (description "Pydbus provides a pythonic interface to the D-Bus
+message bus system.  Pydbus can be used to access remote objects and
+also for object publication.  It is based on PyGI, the Python GObject
+Introspection bindings, which is the recommended way to use GLib from Python.")
+    (license license:lgpl2.1+)))
+
 (define-public python-notify2
   (package
     (name "python-notify2")