diff mbox series

[bug#50045,André,A.,Gomes] Documentation fix

Message ID 874kbtigs7.fsf@gmail.com
State New
Headers show
Series [bug#50045,André,A.,Gomes] Documentation fix | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

André A. Gomes Aug. 13, 2021, 2:02 p.m. UTC
Hi Guix,

I noticed that unless geiser-guile-load-path is given an absolute path,
emacs-guix doesn't work properly.

Here's a recipe to see it failing:

Write a file, say test-emacs.el:

--8<---------------cut here---------------start------------->8---
(with-eval-after-load 'geiser-guile
  (add-to-list 'geiser-guile-load-path "~/src/guix"))
--8<---------------cut here---------------end--------------->8---

$ emacs -q -l /path/to/test-emacs.el

M-x guix p n

--8<---------------cut here---------------start------------->8---
Starting Guix REPL ... [5 times]
guix-geiser-eval: Error in evaluating guile expression: ice-9/boot-9.scm:1685:16: In procedure raise-exception:
error: package-names*: unbound variable

Entering a new prompt.  Type `,bt' for a backtrace or `,q' to continue.
scheme@(emacs-guix) [1]>
--8<---------------cut here---------------end--------------->8---

The attached patch fixes the code snippet in the documentation, thus
preventing others from stumbling on it.

Thank you.


--
André A. Gomes
"Free Thought, Free World"

Comments

Nicolas Goaziou Jan. 15, 2022, 10:04 p.m. UTC | #1
Hello,

André A. Gomes <andremegafone@gmail.com> writes:

> I noticed that unless geiser-guile-load-path is given an absolute path,
> emacs-guix doesn't work properly.
>
> Here's a recipe to see it failing:
>
> Write a file, say test-emacs.el:
>
> --8<---------------cut here---------------start------------->8---
> (with-eval-after-load 'geiser-guile
>   (add-to-list 'geiser-guile-load-path "~/src/guix"))
> --8<---------------cut here---------------end--------------->8---
>
>
> $ emacs -q -l /path/to/test-emacs.el
>
> M-x guix p n
>
> --8<---------------cut here---------------start------------->8---
> Starting Guix REPL ... [5 times]
> guix-geiser-eval: Error in evaluating guile expression: ice-9/boot-9.scm:1685:16: In procedure raise-exception:
> error: package-names*: unbound variable
>
> Entering a new prompt.  Type `,bt' for a backtrace or `,q' to continue.
> scheme@(emacs-guix) [1]>
> --8<---------------cut here---------------end--------------->8---
>
> The attached patch fixes the code snippet in the documentation, thus
> preventing others from stumbling on it.

Thank you for your patch. However it is merely a workaround:
"~/src/guix" _is_ an absolute path. I think there's a problem upstream.

However, emacs-geiser-guile package was updated a few times since your
bug report. Maybe the issue is already fixed. Could you confirm it?

Regards,
André A. Gomes Jan. 21, 2022, 7:06 p.m. UTC | #2
Hi Nicolas,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

>> Here's a recipe to see it failing:
>>
>> Write a file, say test-emacs.el:
>>
>> --8<---------------cut here---------------start------------->8---
>> (with-eval-after-load 'geiser-guile
>>   (add-to-list 'geiser-guile-load-path "~/src/guix"))
>> --8<---------------cut here---------------end--------------->8---
>>
>> $ emacs -q -l /path/to/test-emacs.el
>>
>> M-x guix p n
>>
>> --8<---------------cut here---------------start------------->8---
>> Starting Guix REPL ... [5 times]
>> guix-geiser-eval: Error in evaluating guile expression: ice-9/boot-9.scm:1685:16: In procedure raise-exception:
>> error: package-names*: unbound variable
>>
>> Entering a new prompt.  Type `,bt' for a backtrace or `,q' to continue.
>> scheme@(emacs-guix) [1]>
>> --8<---------------cut here---------------end--------------->8---
>
> Thank you for your patch. However it is merely a workaround:
> "~/src/guix" _is_ an absolute path. I think there's a problem upstream.
>
> However, emacs-geiser-guile package was updated a few times since your
> bug report. Maybe the issue is already fixed. Could you confirm it?

This is still an issue, despite the recent updates.  I'm still as
baffled as I was when I reported.  How could I investigate this further?
Thanks.

Let me restate the issue for the sake of clarity.

Write the s-exp below to a file, let's call it test-emacs-guix.el.

--8<---------------cut here---------------start------------->8---
(with-eval-after-load 'geiser-guile
  (add-to-list 'geiser-guile-load-path "~/path/to/guix/checkout/"))
--8<---------------cut here---------------end--------------->8---

--8<---------------cut here---------------start------------->8---
$ emacs -nw -q -l test-emacs-guix.el
--8<---------------cut here---------------end--------------->8---

M-x guix RET p ; n.  The Guix REPL raises the error mentioned in my
previous message.

When I change the path to /home/$USER/path/to/guix/checkout, the REPL is
successfully started.


--
André A. Gomes
"Free Thought, Free World"
Nicolas Goaziou Jan. 21, 2022, 8:41 p.m. UTC | #3
Hello,

André A. Gomes <andremegafone@gmail.com> writes:

> This is still an issue, despite the recent updates.  I'm still as
> baffled as I was when I reported.  How could I investigate this further?
> Thanks.
>
> Let me restate the issue for the sake of clarity.
>
> Write the s-exp below to a file, let's call it test-emacs-guix.el.
>
> --8<---------------cut here---------------start------------->8---
> (with-eval-after-load 'geiser-guile
>   (add-to-list 'geiser-guile-load-path "~/path/to/guix/checkout/"))
> --8<---------------cut here---------------end--------------->8---
>
> --8<---------------cut here---------------start------------->8---
> $ emacs -nw -q -l test-emacs-guix.el
> --8<---------------cut here---------------end--------------->8---
>
> M-x guix RET p ; n.  The Guix REPL raises the error mentioned in my
> previous message.

FWIW, I cannot reproduce it. With the command above, I get a prompt in
the minibuffer, without an error.

> When I change the path to /home/$USER/path/to/guix/checkout, the REPL is
> successfully started.

Have you tried to contact Geiser's author? They may have at least a clue
about this.

Regards,
André A. Gomes Feb. 11, 2022, 7:36 p.m. UTC | #4
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> FWIW, I cannot reproduce it. With the command above, I get a prompt in
> the minibuffer, without an error.

Interesting.  I tried to investigate this further without any luck.  The
issue persists but I have no clue.
André A. Gomes Nov. 2, 2023, 9:45 a.m. UTC | #5
No meaningful conclusion.  Closing.
diff mbox series

Patch

From 5c402baa846f1a3bb330b4430c0dd2ae4c0da944 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andr=C3=A9=20A=2E=20Gomes?= <andremegafone@gmail.com>
Date: Fri, 13 Aug 2021 16:22:13 +0300
Subject: [PATCH] doc: Fix code snippet.

* doc/contributing.texi (Contributing The Perfect Setup): Use absolute paths.
---
 doc/contributing.texi | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/doc/contributing.texi b/doc/contributing.texi
index d1b77d7d05..23e11d6408 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -256,7 +256,7 @@  that it finds source files from your checkout:
 @lisp
 ;; @r{Assuming the Guix checkout is in ~/src/guix.}
 (with-eval-after-load 'geiser-guile
-  (add-to-list 'geiser-guile-load-path "~/src/guix"))
+  (add-to-list 'geiser-guile-load-path (expand-file-name "~/src/guix")))
 @end lisp

 To actually edit the code, Emacs already has a neat Scheme mode.  But in
--
2.32.0