diff mbox series

[bug#52932] gnu: uim: Build with '-O2'.

Message ID CAGNyvej-DiFFns=vappj0yE_t-7VbOLNx4_EnTMCMF4vevNTRA@mail.gmail.com
State Accepted
Headers show
Series [bug#52932] gnu: uim: Build with '-O2'. | expand

Commit Message

路辉 Jan. 1, 2022, 1:08 p.m. UTC
* gnu/packages/xorg.scm (uim) [arguments]: Pass "-O2 -g".
---
 gnu/packages/xorg.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Leo Famulari Jan. 2, 2022, 3:58 a.m. UTC | #1
On Sat, Jan 01, 2022 at 01:08:13PM +0000, 路辉 wrote:
> * gnu/packages/xorg.scm (uim) [arguments]: Pass "-O2 -g".

Thanks! I see this fixes the build.

> +             "CFLAGS=-O2 -g -fcommon")

Did you mean to use '-fcommon' too? It's not in the commit message.
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b09d95f770..fa747ebac4 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -32,6 +32,7 @@ 
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2021 qblade <qblade@protonmail.com>
+;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6446,7 +6447,8 @@  (define-public uim
        (list "--with-anthy-utf8"
              (string-append "--with-lispdir=" %output "/share/emacs")
              ;; Set proper runpath
-             (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
+             (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")
+             "CFLAGS=-O2 -g -fcommon")
        #:phases
        (modify-phases %standard-phases
          ;; Set path of uim-el-agent and uim-el-helper-agent executables