diff mbox series

[bug#52583] Add texlive-latex-numprint

Message ID 87ilvn9iy6.fsf@nicolasgoaziou.fr
State Accepted
Headers show
Series [bug#52583] Add texlive-latex-numprint | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Goaziou Dec. 17, 2021, 6:37 p.m. UTC
Hello,

This patch adds texlive-latex-numprint.

Regards,

Comments

Mathieu Othacehe Dec. 26, 2021, 5:47 p.m. UTC | #1
Hello Nicolas,

> This patch adds texlive-latex-numprint.

Looks fine, thanks!

Mathieu
Nicolas Goaziou Dec. 26, 2021, 8:33 p.m. UTC | #2
Hello,

Mathieu Othacehe <othacehe@gnu.org> writes:

> Looks fine, thanks!

Applied. Thanks!

Regards,
diff mbox series

Patch

From 9522e8ee96f96c4f8669124a38cc214fd14ea4c1 Mon Sep 17 00:00:00 2001
Message-Id: <9522e8ee96f96c4f8669124a38cc214fd14ea4c1.1639766179.git.mail@nicolasgoaziou.fr>
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Fri, 17 Dec 2021 19:34:42 +0100
Subject: [PATCH] gnu: Add texlive-latex-numprint.

* gnu/packages/tex.scm (texlive-latex-numprint): New variable.
---
 gnu/packages/tex.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ebb7f86552..ac66c6f7c4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7493,6 +7493,41 @@  (define-public texlive-latex-ms
 @end itemize\n")
     (license license:lppl1.3c+)))
 
+(define-public texlive-latex-numprint
+  (package
+    (name "texlive-latex-numprint")
+    (version (number->string %texlive-revision))
+    (source
+     (origin
+       (method svn-fetch)
+       (uri (texlive-ref "latex" "numprint"))
+       (file-name (string-append name "-" version "-checkout"))
+       (sha256
+        (base32 "00xyvdfvypfj2wj7wf2qrxpc34wwd0dkdv3bqvb86ydhlpn1jg76"))))
+    (build-system texlive-build-system)
+    (arguments '(#:tex-directory "latex/numprint"))
+    (home-page "https://www.ctan.org/pkg/numprint")
+    (synopsis "Print numbers with separators and exponent if necessary")
+    (description
+     "The package numprint prints numbers with a separator every three
+digits and converts numbers given as 12345.6e789 to 12\\,345,6\\cdot
+10^{789}.  Numbers are printed in the current mode (text or math) in
+order to use the correct font.
+
+Many things, including the decimal sign, the thousand separator, as
+well as the product sign can be changed by the user, e.g., to reach
+12,345.6\\times 10^{789}.
+
+If an optional argument is given it is printed upright as unit.
+Numbers can be rounded to a given number of digits.  The package
+supports an automatic, language-dependent change of the number format.
+
+Tabular alignment using the tabular, array, tabularx, and longtable
+environments (similar to the dcolumn and rccol packages) is supported
+using all features of numprint.  Additional text can be added before
+and after the formatted number.")
+    (license license:lppl)))
+
 (define-public texlive-latex-needspace
   (package
     (name "texlive-latex-needspace")
-- 
2.34.0