diff mbox series

[bug#52592] gnu: mono: Update to 4.8.1.0.

Message ID CAJsg1E8XBCDa+rAZKg5Zfhi3msBMxU5uKbKh2njbC+06NuH1iw@mail.gmail.com
State Accepted
Headers show
Series [bug#52592] gnu: mono: Update to 4.8.1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andy Tai Dec. 18, 2021, 1:20 a.m. UTC

Comments

Leo Famulari Dec. 18, 2021, 8 p.m. UTC | #1
On Fri, Dec 17, 2021 at 05:20:29PM -0800, Andy Tai wrote:
> 

> From bad68e7f6396169007ae707a029c0779f627f306 Mon Sep 17 00:00:00 2001
> From: Andy Tai <atai@atai.org>
> Date: Fri, 17 Dec 2021 17:14:59 -0800
> Subject: [PATCH] gnu: mono: Update to 4.8.1.0.
> To: guix-patches@gnu.org
> 
> gnu/packages/mono.scm (mono): Update to 4.8.1.0.

Thanks for the patch!

>      (native-inputs
> -     `(("gettext" ,gettext-minimal)
> +     `(("cmake" ,cmake-minimal)
> +       ("gettext" ,gettext-minimal)

Just checking, is the addition of cmake-minimal intentional? It wasn't
mentioned in the commit message.
Andy Tai Dec. 18, 2021, 9:25 p.m. UTC | #2
Yes, it is intentional.    The build process needs cmake.  I am not
sure how that is to be stated in the commit message.

On Sat, Dec 18, 2021 at 12:00 PM Leo Famulari <leo@famulari.name> wrote:
>
> On Fri, Dec 17, 2021 at 05:20:29PM -0800, Andy Tai wrote:
> >
>
> > From bad68e7f6396169007ae707a029c0779f627f306 Mon Sep 17 00:00:00 2001
> > From: Andy Tai <atai@atai.org>
> > Date: Fri, 17 Dec 2021 17:14:59 -0800
> > Subject: [PATCH] gnu: mono: Update to 4.8.1.0.
> > To: guix-patches@gnu.org
> >
> > gnu/packages/mono.scm (mono): Update to 4.8.1.0.
>
> Thanks for the patch!
>
> >      (native-inputs
> > -     `(("gettext" ,gettext-minimal)
> > +     `(("cmake" ,cmake-minimal)
> > +       ("gettext" ,gettext-minimal)
>
> Just checking, is the addition of cmake-minimal intentional? It wasn't
> mentioned in the commit message.
Leo Famulari Dec. 18, 2021, 11:45 p.m. UTC | #3
On Sat, Dec 18, 2021 at 01:25:48PM -0800, Andy Tai wrote:
> Yes, it is intentional.    The build process needs cmake.  I am not
> sure how that is to be stated in the commit message.

Okay. The commit message would look like this:

------
gnu: mono: Update to 4.8.1.0.

gnu/packages/mono.scm (mono): Update to 4.8.1.0.
[native-inputs]: Add cmake-minimal
------

I amended the commit message, applied the patch on the 'master' branch
[0], and then built the package. However, it fails to build, like this:

------
Assembling 'event-il.il' , no listing file, to exe --> 'event-il.exe'

Operation completed successfully
MONO_PATH=/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x ../../runtime/mono-wrapper /tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x/ilasm.exe -out:module-cctor.exe module-cctor.il
Assembling 'module-cctor.il' , no listing file, to exe --> 'module-cctor.exe'

Operation completed successfully
make[5]: *** No rule to make target 'TestingReferenceAssembly.dll', needed by 'runtest-managed'.  Stop.
make[5]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
make[4]: *** [Makefile:1874: testjit] Error 2
make[4]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
make[3]: *** [Makefile:1584: check-am] Error 2
make[3]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
make[2]: *** [Makefile:1436: check-recursive] Error 1
make[2]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
make[1]: *** [Makefile:445: check-recursive] Error 1
make[1]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono'
make: *** [Makefile:525: check-recursive] Error 1

Test suite failed, dumping logs.
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe") exit-status: 2 term-signal: #f stop-signal: #f> 
phase `check' failed after 215.7 seconds
command "make" "check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe" failed with status 2
builder for `/gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv' failed with exit code 1
build of /gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv failed
------

Any ideas? Does it work for you?

[0] On commit f6e79ef108a206a2fb3db550d76de760d581f8a8
Andy Tai Dec. 19, 2021, 12:25 a.m. UTC | #4
It did pass for me.  I am not sure why the behavior can be different.

On Sat, Dec 18, 2021 at 3:45 PM Leo Famulari <leo@famulari.name> wrote:
>
> On Sat, Dec 18, 2021 at 01:25:48PM -0800, Andy Tai wrote:
> > Yes, it is intentional.    The build process needs cmake.  I am not
> > sure how that is to be stated in the commit message.
>
> Okay. The commit message would look like this:
>
> ------
> gnu: mono: Update to 4.8.1.0.
>
> gnu/packages/mono.scm (mono): Update to 4.8.1.0.
> [native-inputs]: Add cmake-minimal
> ------
>
> I amended the commit message, applied the patch on the 'master' branch
> [0], and then built the package. However, it fails to build, like this:
>
> ------
> Assembling 'event-il.il' , no listing file, to exe --> 'event-il.exe'
>
> Operation completed successfully
> MONO_PATH=/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x ../../runtime/mono-wrapper /tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x/ilasm.exe -out:module-cctor.exe module-cctor.il
> Assembling 'module-cctor.il' , no listing file, to exe --> 'module-cctor.exe'
>
> Operation completed successfully
> make[5]: *** No rule to make target 'TestingReferenceAssembly.dll', needed by 'runtest-managed'.  Stop.
> make[5]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> make[4]: *** [Makefile:1874: testjit] Error 2
> make[4]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> make[3]: *** [Makefile:1584: check-am] Error 2
> make[3]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> make[2]: *** [Makefile:1436: check-recursive] Error 1
> make[2]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> make[1]: *** [Makefile:445: check-recursive] Error 1
> make[1]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono'
> make: *** [Makefile:525: check-recursive] Error 1
>
> Test suite failed, dumping logs.
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe") exit-status: 2 term-signal: #f stop-signal: #f>
> phase `check' failed after 215.7 seconds
> command "make" "check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe" failed with status 2
> builder for `/gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv' failed with exit code 1
> build of /gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv failed
> ------
>
> Any ideas? Does it work for you?
>
> [0] On commit f6e79ef108a206a2fb3db550d76de760d581f8a8
Andy Tai Dec. 19, 2021, 1:28 a.m. UTC | #5
In any case, if you want to revert it, go ahead. I am now trying to
upgrade to Mono 6.

On Sat, Dec 18, 2021 at 4:25 PM Andy Tai <atai@atai.org> wrote:
>
> It did pass for me.  I am not sure why the behavior can be different.
>
> On Sat, Dec 18, 2021 at 3:45 PM Leo Famulari <leo@famulari.name> wrote:
> >
> > On Sat, Dec 18, 2021 at 01:25:48PM -0800, Andy Tai wrote:
> > > Yes, it is intentional.    The build process needs cmake.  I am not
> > > sure how that is to be stated in the commit message.
> >
> > Okay. The commit message would look like this:
> >
> > ------
> > gnu: mono: Update to 4.8.1.0.
> >
> > gnu/packages/mono.scm (mono): Update to 4.8.1.0.
> > [native-inputs]: Add cmake-minimal
> > ------
> >
> > I amended the commit message, applied the patch on the 'master' branch
> > [0], and then built the package. However, it fails to build, like this:
> >
> > ------
> > Assembling 'event-il.il' , no listing file, to exe --> 'event-il.exe'
> >
> > Operation completed successfully
> > MONO_PATH=/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x ../../runtime/mono-wrapper /tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x/ilasm.exe -out:module-cctor.exe module-cctor.il
> > Assembling 'module-cctor.il' , no listing file, to exe --> 'module-cctor.exe'
> >
> > Operation completed successfully
> > make[5]: *** No rule to make target 'TestingReferenceAssembly.dll', needed by 'runtest-managed'.  Stop.
> > make[5]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> > make[4]: *** [Makefile:1874: testjit] Error 2
> > make[4]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> > make[3]: *** [Makefile:1584: check-am] Error 2
> > make[3]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> > make[2]: *** [Makefile:1436: check-recursive] Error 1
> > make[2]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> > make[1]: *** [Makefile:445: check-recursive] Error 1
> > make[1]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono'
> > make: *** [Makefile:525: check-recursive] Error 1
> >
> > Test suite failed, dumping logs.
> > error: in phase 'check': uncaught exception:
> > %exception #<&invoke-error program: "make" arguments: ("check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe") exit-status: 2 term-signal: #f stop-signal: #f>
> > phase `check' failed after 215.7 seconds
> > command "make" "check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe" failed with status 2
> > builder for `/gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv' failed with exit code 1
> > build of /gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv failed
> > ------
> >
> > Any ideas? Does it work for you?
> >
> > [0] On commit f6e79ef108a206a2fb3db550d76de760d581f8a8
>
>
>
> --
> Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
> Year 2021 民國110年
> 自動的精神力是信仰與覺悟
> 自動的行為力是勞動與技能
Leo Famulari Dec. 20, 2021, 5:56 p.m. UTC | #6
On Sat, Dec 18, 2021 at 05:28:37PM -0800, Andy Tai wrote:
> In any case, if you want to revert it, go ahead. I am now trying to
> upgrade to Mono 6.

No need to revert, because I had only applied it locally. I hadn't yet
pushed to Savannah. Maybe it's a non-deterministic build failure. I'll
try building on one core and similar things.
diff mbox series

Patch

From bad68e7f6396169007ae707a029c0779f627f306 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Fri, 17 Dec 2021 17:14:59 -0800
Subject: [PATCH] gnu: mono: Update to 4.8.1.0.
To: guix-patches@gnu.org

gnu/packages/mono.scm (mono): Update to 4.8.1.0.
---
 gnu/packages/mono.scm | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/mono.scm b/gnu/packages/mono.scm
index 6a7afbafbf..8dad3c547a 100644
--- a/gnu/packages/mono.scm
+++ b/gnu/packages/mono.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19,6 +20,9 @@ 
 
 (define-module (gnu packages mono)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix utils)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages cmake)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
@@ -33,12 +37,13 @@  (define-module (gnu packages mono)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu))
 
 (define-public mono
   (package
     (name "mono")
-    (version "4.4.1.0")
+    (version "4.8.1.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -47,11 +52,12 @@  (define-public mono
                     ".tar.bz2"))
               (sha256
                (base32
-                "0jibyvyv2jy8dq5ij0j00iq3v74r0y90dcjc3dkspcfbnn37cphn"))
+                "1vyvp2g28ihcgxgxr8nhzyzdmzicsh5djzk8dk1hj5p5f2k3ijqq"))
               (patches (search-patches "mono-mdoc-timestamping.patch"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("gettext" ,gettext-minimal)
+     `(("cmake" ,cmake-minimal)
+       ("gettext" ,gettext-minimal)
        ("glib" ,glib)
        ("libxslt" ,libxslt)
        ("perl" ,perl)

base-commit: b4ee524e5adb2153a0de607a32100a8db2b12585
prerequisite-patch-id: 0bc0b33477cdab26d37501579ca950e4cbf6e050
-- 
2.34.0