diff mbox series

[bug#51212] gnu: pipewire-0.3: Update to 0.3.38.

Message ID BYAPR05MB4023B67DB85B0F7C6D079310C5B89@BYAPR05MB4023.namprd05.prod.outlook.com
State Accepted
Headers show
Series [bug#51212] gnu: pipewire-0.3: Update to 0.3.38. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Morgan Smith Oct. 14, 2021, 7:14 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/linux.scm (pipewire-0.3): Update to 0.3.38.
[meson] Use meson-0.55.
[phases] Don't delete shrink-runpath.
[native-inputs] Add pipewire native-inputs to enable documentation generation.
---

I installed this on my system and it works great. I also read the release notes
but none of them mention to newer meson dependency so maybe that's not a good
metric to determine if any more changes are needed :P.


 gnu/packages/linux.scm | 17 ++++++++---------
 1 file changed, 8 insertions(+), 9 deletions(-)

Comments

Morgan Smith Nov. 2, 2021, 11:26 p.m. UTC | #1
The latest and greatest pipewire stopped bundling session managers into the repo so now we gotta build a session manager separately.
Timmy Douglas Dec. 16, 2021, 7:30 p.m. UTC | #2
Morgan.J.Smith@outlook.com writes:

> The latest and greatest pipewire stopped bundling session managers
> into the repo so now we gotta build a session manager separately.

+1. I just upgraded and noticed my audio stopped working now that
pipewire-media-session is gone. I just noticed this patch set:

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=52492

which also adds it and cleans a few things up.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0088dbad4a..ee5c78c0e1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -80,6 +80,7 @@  (define-module (gnu packages linux)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages build-tools)
   #:use-module (gnu packages calendar)
   #:use-module (gnu packages check)
   #:use-module (gnu packages cpio)
@@ -8046,7 +8047,7 @@  (define-public pipewire-0.3
   (package
     (inherit pipewire)
     (name "pipewire")
-    (version "0.3.29")
+    (version "0.3.38")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -8055,23 +8056,21 @@  (define-public pipewire-0.3
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "16jjxcnahxqfcawz77ywx837ybhwzcivn7hgqb9cmlp1y2syy8gk"))))
+                "15alnzwdgjbjrmphyinwdbaa1bi9cqbk8gkhrb4y6akjqph76hs0"))))
     (arguments
-     '(#:configure-flags
+     `(#:meson ,meson-0.55
+       #:configure-flags
        (list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
                             "/lib/udev/rules.d")
-             "-Dsystemd=disabled")
-       #:phases
-       (modify-phases %standard-phases
-         ;; Skip shrink-runpath, otherwise validate-runpath fails.
-         (delete 'shrink-runpath))))
+             "-Dsystemd=disabled")))
     (inputs
      (append (package-inputs pipewire)
              `(("bluez" ,bluez)
                ("jack" ,jack-2)
                ("pulseaudio" ,pulseaudio)
                ("vulkan-loader" ,vulkan-loader)
-               ("vulkan-headers" ,vulkan-headers))))))
+               ("vulkan-headers" ,vulkan-headers))))
+    (native-inputs (package-native-inputs pipewire))))
 
 (define-public ell
   (package