diff mbox series

[bug#51730,19/21] gnu: Add rust-wl-clipboard-rs-0.4.

Message ID HjK6N6NIuzfFe7MNZQBagxBV2JO3PV1HzIS130OFm9j63WWBhMfDVdSwuvTXGBewzii7zNQ0rOTOYoQ7yiRWV7hNVwwp7hNYw7ztaWFo7X8=@protonmail.com
State Accepted
Headers show
Series None | expand

Commit Message

phodina Dec. 3, 2021, 2:11 p.m. UTC
Hi Nicolas,

> Hello,
>
> phodina via Guix-patches via guix-patches@gnu.org writes:
>
> > -   gnu/packages/crates-graphics.scm (rust-wl-clipboard-rs-0.4): New variable.
> > -   gnu/packages/patches/rust-wl-clipboard-rs-newer-wl.patch: New file.
> > -   gnu/local.mk: Add patch.
>
> This patch does not apply on current master + all previous patches.
>
> Also, I don't think it belongs to "crate-graphics.scm" but rather to
>
> "crates-io.scm".
>

I've rebased the patches on top of the latest master branch and fixed the conflicts.

I was looking for wayland crates therefore I put it in crates-graphics.scm. However, I agree with you the crates-io.scm is a better place.

Note that the order of rust-thread-local-0.3.4 and rust-stderrlog-0.4 is swapped.

----
Petr

Comments

Nicolas Goaziou Dec. 3, 2021, 8:13 p.m. UTC | #1
Hello,

phodina <phodina@protonmail.com> writes:

> I've rebased the patches on top of the latest master branch and fixed
> the conflicts.

Thank you.

> I was looking for wayland crates therefore I put it in crates-graphics.scm. However, I agree with you the crates-io.scm is a better place.
>
> Note that the order of rust-thread-local-0.3.4 and rust-stderrlog-0.4
> is swapped.

Is it possible to relax requirements in rust-stderrlog-0.4 so it accepts
rust-thread-local-0.3.6? See, e.g., rust-average-0.13.

Regards,
phodina Dec. 7, 2021, 10:31 p.m. UTC | #2
Hi Nicolas,

On Friday, December 3rd, 2021 at 9:13 PM, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

> Hello,
>
> phodina phodina@protonmail.com writes:
>
> > I've rebased the patches on top of the latest master branch and fixed
> >
> > the conflicts.
>
> Thank you.
>
> > I was looking for wayland crates therefore I put it in crates-graphics.scm. However, I agree with you the crates-io.scm is a better place.
> >
> > Note that the order of rust-thread-local-0.3.4 and rust-stderrlog-0.4
> >
> > is swapped.
>
> Is it possible to relax requirements in rust-stderrlog-0.4 so it accepts
>
> rust-thread-local-0.3.6? See, e.g., rust-average-0.13.
>
> Regards,
> --------------------------------------------------------------------------------------------------------------------------------------------
>
> Nicolas Goaziou

Thanks for the tip. I've used that in the past. However, the package in question rust-stderrlog-0.4 has requirement which makes that very hard to relax:

Caused by:
  failed to select a version for the requirement `thread_local = "^0.3, <=0.3.4"`
  candidate versions found which didn't match: 0.3.6

I'd rather just add the package definition than modify the requirement only to discover some wierd issues later.

Is it possible to just add the package rust-thread-local in this specific version and later when the dependency (rust-stderrlog) of spotify-tui is updated this orphan package could be deleted?

----
Petr
Nicolas Goaziou Dec. 9, 2021, 11:36 p.m. UTC | #3
Hello,

phodina <phodina@protonmail.com> writes:

> Thanks for the tip. I've used that in the past. However, the package in question rust-stderrlog-0.4 has requirement which makes that very hard to relax:
>
> Caused by:
>   failed to select a version for the requirement `thread_local = "^0.3, <=0.3.4"`
>   candidate versions found which didn't match: 0.3.6
>
> I'd rather just add the package definition than modify the requirement only to discover some wierd issues later.
>
> Is it possible to just add the package rust-thread-local in this
> specific version and later when the dependency (rust-stderrlog) of
> spotify-tui is updated this orphan package could be deleted?

Fair enough.

Patches applied. Thank you.

Regards,
diff mbox series

Patch

From 4e2b8675abd3984ea8f78b8e1f89eafbdbdeaac3 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 9 Nov 2021 21:21:25 +0100
Subject: [PATCH v2 15/19] gnu: Add rust-thread-local-0.3.4.

* gnu/packages/crates-io.scm (rust-thread-local-0.3.4): New variable.

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ce30d8f830..4a59f6526e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -54407,6 +54407,25 @@  (define-public rust-thread-local-0.3
      `(#:skip-build? #t
        #:cargo-inputs (("rust-lazy-static" ,rust-lazy-static-1))))))
 
+(define-public rust-thread-local-0.3.4
+  (package
+    (inherit rust-thread-local-0.3)
+    (name "rust-thread-local")
+    (version "0.3.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "thread_local" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "055vj0ddb6vh0zaqdlxssfqzzpgs4ll5l5j7nqvabdzfgasw95qn"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build? #t
+        #:cargo-inputs
+        (("rust-lazy-static" ,rust-lazy-static-0.2)
+         ("rust-unreachable" ,rust-unreachable-1))))))
+
 (define-public rust-thread-local-0.2
   (package
     (inherit rust-thread-local-0.3)
-- 
2.33.1