diff mbox series

[bug#52325] gnu: Add dutree.

Message ID 20211206090533.26893-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#52325] gnu: Add dutree. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

jgart Dec. 6, 2021, 9:05 a.m. UTC
* gnu/packages/rust-apps.scm (dutree): New variable.
---
 gnu/packages/rust-apps.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Efraim Flashner Dec. 7, 2021, 12:03 p.m. UTC | #1
Patch pushed, with a few changes.

On Mon, Dec 06, 2021 at 04:05:33AM -0500, jgart via Guix-patches via wrote:
> * gnu/packages/rust-apps.scm (dutree): New variable.
> ---
>  gnu/packages/rust-apps.scm | 36 ++++++++++++++++++++++++++++++++++++
>  1 file changed, 36 insertions(+)
> 
> diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
> index 5fe18ac942..50095fd38b 100644
> --- a/gnu/packages/rust-apps.scm
> +++ b/gnu/packages/rust-apps.scm
> @@ -989,6 +989,42 @@ (define-public tokei
>  blanks grouped by language.")
>      (license (list license:expat license:asl2.0))))

Not all the packages are sorted alphabetically in rust-apps, but I moved
this one further up with the sorted packages.

>  
> +(define-public dutree
> +  (package
> +    (name "dutree")
> +    (version "0.2.18")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (crate-uri "dutree" version))
> +        (file-name (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32 "1611h27i8fm3jndscd6w65z8z7w09nnrm61vdgs9kb8ln57gqm8x"))))
> +    (build-system cargo-build-system)
> +    (arguments

I added #:install-source? #f to arguments

> +      `(#:cargo-inputs
> +        (("rust-getopts" ,rust-getopts-0.2)
> +         ("rust-regex" ,rust-regex-1)
> +         ("rust-signal-hook" ,rust-signal-hook-0.1)
> +         ("rust-terminal-size" ,rust-terminal-size-0.1)
> +         ("rust-unicode-segmentation" ,rust-unicode-segmentation-1)
> +         ("rust-unicode-width" ,rust-unicode-width-0.1))))
> +    (home-page "https://github.com/nachoparker/dutree")

Changed the home-page to https://ownyourbits.com/2018/03/25/analyze-disk-usage-with-dutree/

> +    (synopsis "Command line tool to analyze disk usage")
> +    (description

Some small tweaks to the description.

> +"@command{dutree} is command line tool to analyze disk usage.
> +Features include:
> +
> +@enumerate
> +@item coloured output, according to the LS_COLORS  environment variable.
> +@item display the file system tree
> +@item ability to aggregate small files
> +@item ability to exclude files or directories
> +@item ability to compare different directories
> +@item fast, written in Rust
> +@end enumerate\n")
> +    (license license:gpl3)))
> +
>  (define-public watchexec
>    (package
>      (name "watchexec")
> -- 
> 2.34.0
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 5fe18ac942..50095fd38b 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -989,6 +989,42 @@  (define-public tokei
 blanks grouped by language.")
     (license (list license:expat license:asl2.0))))
 
+(define-public dutree
+  (package
+    (name "dutree")
+    (version "0.2.18")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "dutree" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "1611h27i8fm3jndscd6w65z8z7w09nnrm61vdgs9kb8ln57gqm8x"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-getopts" ,rust-getopts-0.2)
+         ("rust-regex" ,rust-regex-1)
+         ("rust-signal-hook" ,rust-signal-hook-0.1)
+         ("rust-terminal-size" ,rust-terminal-size-0.1)
+         ("rust-unicode-segmentation" ,rust-unicode-segmentation-1)
+         ("rust-unicode-width" ,rust-unicode-width-0.1))))
+    (home-page "https://github.com/nachoparker/dutree")
+    (synopsis "Command line tool to analyze disk usage")
+    (description
+"@command{dutree} is command line tool to analyze disk usage.
+Features include:
+
+@enumerate
+@item coloured output, according to the LS_COLORS  environment variable.
+@item display the file system tree
+@item ability to aggregate small files
+@item ability to exclude files or directories
+@item ability to compare different directories
+@item fast, written in Rust
+@end enumerate\n")
+    (license license:gpl3)))
+
 (define-public watchexec
   (package
     (name "watchexec")