diff mbox series

[bug#52296,1/4] gnu: Add rust-memchr-2.3.

Message ID 20211205070128.1212-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#52296,1/4] gnu: Add rust-memchr-2.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

jgart Dec. 5, 2021, 7:01 a.m. UTC
* gnu/packages/crates-io.scm (rust-memchr-2.3): New variable.
---
 gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Nicolas Goaziou Dec. 5, 2021, 1:05 p.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/crates-io.scm (rust-memchr-2.3): New variable.

We usually don't add a new Rust package for minor version bumps after
1.0. The way to go would be to relax version requirements in
Cargo.toml so we can use rust-memchr-2. See for example
rust-average-0.13 package.

The same goes for rust-slog-async-2.5 and rust-tempfile-3.1.

Could you give it a try?


Regards,
jgart Dec. 5, 2021, 3:06 p.m. UTC | #2
On Sun, 05 Dec 2021 14:05:36 +0100 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
> Hello,
> 
> jgart via Guix-patches via <guix-patches@gnu.org> writes:
> 
> > * gnu/packages/crates-io.scm (rust-memchr-2.3): New variable.
> 
> We usually don't add a new Rust package for minor version bumps after
> 1.0. The way to go would be to relax version requirements in
> Cargo.toml so we can use rust-memchr-2. See for example
> rust-average-0.13 package.
> 
> The same goes for rust-slog-async-2.5 and rust-tempfile-3.1.

Hi Nicolas,

Thank you for taking the time to review this patch set.

rust-slog and rust-slog-async have the exact same version in the toml file:

```
[dependencies.slog]
version = "~2.5"

[dependencies.slog-async]
version = "~2.5"
```

The versions currently packaged in guix are slog 2.5.2 and slog-async 2.6.0.

I'm stumped on how to differentiate those two using `substitute*`

What do you suggest I do here?
Nicolas Goaziou Dec. 5, 2021, 6:13 p.m. UTC | #3
Hello,

jgart <jgart@dismail.de> writes:

> rust-slog and rust-slog-async have the exact same version in the toml file:
>
> ```
> [dependencies.slog]
> version = "~2.5"
>
> [dependencies.slog-async]
> version = "~2.5"
> ```
>
> The versions currently packaged in guix are slog 2.5.2 and slog-async 2.6.0.
>
> I'm stumped on how to differentiate those two using `substitute*`
>
> What do you suggest I do here?

In a subtle fashion, I would change both to "^2" and cross fingers.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7d5833ffc0..8bc49fcce6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2021 Jacob Hrbek <kreyren@rixotstudio.cz>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29019,6 +29020,26 @@  (define-public rust-measureme-0.7
 unstable -Z self-profile flag.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-memchr-2.3
+  (package
+    (name "rust-memchr")
+    (version "2.3.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "memchr" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "098m9clfs495illlw00hv2gg67mhm7jflld3msyclvi5m9xc9q8f"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build? #t #:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
+    (home-page "https://github.com/BurntSushi/memchr")
+    (synopsis "Safe interface to memchr.")
+    (description "Safe interface to memchr.")
+    (license 
+      (list license:unlicense license:expat))))
+
 (define-public rust-memchr-2
   (package
     (name "rust-memchr")