diff mbox series

[bug#52279] gnu: Add emacs-cc-mode.

Message ID ca95ecee78cae39c7290b4fb7544c7c42958ddcc.camel@gmail.com
State Accepted
Headers show
Series [bug#52279] gnu: Add emacs-cc-mode. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Liliana Marie Prikler Nov. 26, 2021, 4:43 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-cc-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Nicolas Goaziou Dec. 4, 2021, 5:48 p.m. UTC | #1
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-cc-mode): New variable.

Thank you.

LGTM, barring one comment below:

> +    "CC Mode is an Emacs and XEmacs mode for editing C and other languages with
> +similar syntax; currently C++, Objective-C, Java, CORBA's IDL, Pike, and AWK.
> +It's a standard package in both Emacs and XEmacs.  This package provides the
> +upstream release rather than the version bundled with Emacs.")

We didn't add the last sentences for other packages in the same
situation (e.g., Tramp, Org…). I think you should remove it.

Regards,
Liliana Marie Prikler Dec. 4, 2021, 6:28 p.m. UTC | #2
Am Samstag, den 04.12.2021, 18:48 +0100 schrieb Nicolas Goaziou:
> Hello,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/emacs-xyz.scm (emacs-cc-mode): New variable.
> 
> Thank you.
> 
> LGTM, barring one comment below:
> 
> > +    "CC Mode is an Emacs and XEmacs mode for editing C and other
> > languages with
> > +similar syntax; currently C++, Objective-C, Java, CORBA's IDL,
> > Pike, and AWK.
> > +It's a standard package in both Emacs and XEmacs.  This package
> > provides the
> > +upstream release rather than the version bundled with Emacs.")
> 
> We didn't add the last sentences for other packages in the same
> situation (e.g., Tramp, Org…). I think you should remove it.
Thanks for the review, but this was sent in error; the "real" cc-mode
patch was sent as 52127 first (but is identical to this one).  I'll
still push it with that adjustment if there's nothing else, though.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 865e0b52d9..962696d8ce 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13838,6 +13838,41 @@  (define-public emacs-boon
 reached with the right hand.")
     (license license:gpl3+)))
 
+(define-public emacs-cc-mode
+  (package
+   (name "emacs-cc-mode")
+   (version "5.35")
+   (source
+    (origin
+     (method hg-fetch)
+     (uri (hg-reference
+           (url "http://hg.code.sf.net/p/cc-mode/cc-mode")
+           (changeset
+            (string-append "Release_"
+                           (string-replace-substring version "." "_")))))
+     (file-name (hg-file-name name version))
+     (sha256
+      (base32 "03cvl61baccx57zd62nz2wy4hvij5hl2syg7byaxgrs4c7grr414"))))
+   (build-system emacs-build-system)
+   (arguments
+    '(#:tests? #t
+      #:test-command '("make" "test")
+      #:phases
+      (modify-phases %standard-phases
+        (add-before 'install 'make-info
+          (lambda _
+            (invoke "make" "info"))))))
+   (native-inputs
+    `(("texinfo" ,texinfo)))
+   (home-page "http://cc-mode.sourceforge.net/")
+   (synopsis "Framework for creating major modes for C-style languages")
+   (description
+    "CC Mode is an Emacs and XEmacs mode for editing C and other languages with
+similar syntax; currently C++, Objective-C, Java, CORBA's IDL, Pike, and AWK.
+It's a standard package in both Emacs and XEmacs.  This package provides the
+upstream release rather than the version bundled with Emacs.")
+   (license license:gpl3+)))
+
 (define-public emacs-csharp-mode
   (package
     (name "emacs-csharp-mode")