diff mbox series

[bug#51188] gnu: emacs: Find real GVFS processes.

Message ID e2f7cf953c7e899c5d0ce8752c70cfd611e534e3.camel@gmail.com
State Accepted
Headers show
Series [bug#51188] gnu: emacs: Find real GVFS processes. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Liliana Marie Prikler Oct. 13, 2021, 7:32 p.m. UTC
* gnu/packages/emacs.scm (emacs)[#:phases]<patch-program-file-names>: Expand
calls to “tramp-compat-process-running-p” so that Guix wrappers are also
matched.
---
 gnu/packages/emacs.scm | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Liliana Marie Prikler Dec. 3, 2021, 8:40 p.m. UTC | #1
Pushed as f725279cdd66e7739fd756807ef2a1c7b1611d51.
diff mbox series

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6d9950d068..a59931ddc4 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -136,6 +136,12 @@ 
                             "lisp/progmodes/sh-script.el")
                (("\"/bin/sh\"")
                 (format #f "~s" (which "sh"))))
+             ;; match ".gvfs-fuse-daemon-real" and ".gvfsd-fuse-real"
+             ;; respectively when looking for GVFS processes.
+             (substitute* "lisp/net/tramp-gvfs.el"
+               (("\\(tramp-compat-process-running-p \"(.*)\"\\)" all process)
+                (format #f "(or ~a (tramp-compat-process-running-p ~s))"
+                        all (string-append "." process "-real"))))
              #t))
          (add-before 'configure 'fix-/bin/pwd
            (lambda _