diff mbox series

[bug#52180] maintenance: Disable ARM emulation.

Message ID 87mtlnj9in.fsf@gnu.org
State Accepted
Headers show
Series [bug#52180] maintenance: Disable ARM emulation. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Mathieu Othacehe Nov. 29, 2021, 2:56 p.m. UTC
Hello,

The Cuirass instance on Berlin is now connected to three more ARM
machines: grunewald, pankow and kreuzberg thanks to Ricardo! We can now
hopefully stop relying on ARM emulated builds.

Here's a patch on maintenance to disable running ARM emulated builds on
hydra-guix build nodes. Those emulated builds are known to fail in
various ways when native builds work properly.

Thanks,

Mathieu

Comments

Mathieu Othacehe Dec. 3, 2021, 9:46 a.m. UTC | #1
> * hydra/berlin-nodes.scm: Disable armhf-linux and aarch64-linux system
> emulation on build nodes.

Pushed as 353e955dc322c8355f98d5f0436dff7011c8fe30.

Thanks,

Mathieu
diff mbox series

Patch

From d2b2a9a714f9d5140690682ef64968bebd06327a Mon Sep 17 00:00:00 2001
From: Mathieu Othacehe <othacehe@gnu.org>
Date: Mon, 29 Nov 2021 15:48:50 +0100
Subject: [PATCH 1/1] hydra: Disable ARM emulation.

* hydra/berlin-nodes.scm: Disable armhf-linux and aarch64-linux system
emulation on build nodes.
---
 hydra/berlin-nodes.scm | 8 +-------
 1 file changed, 1 insertion(+), 7 deletions(-)

diff --git a/hydra/berlin-nodes.scm b/hydra/berlin-nodes.scm
index c8f035b..92bef7a 100644
--- a/hydra/berlin-nodes.scm
+++ b/hydra/berlin-nodes.scm
@@ -136,14 +136,8 @@ 
                                         #:emulated-architectures
                                         '("arm" "aarch64" "ppc64le")
                                         #:childhurd? (childhurd-ip? ip)
-                                        ;; Emulate foreign architectures on
-                                        ;; half of the build machines.
                                         #:systems
-                                        `("x86_64-linux" "i686-linux"
-                                          ,@(if (odd? id)
-                                                '("armhf-linux"
-                                                  "aarch64-linux")
-                                                '()))
+                                        `("x86_64-linux" "i686-linux")
                                         #:max-jobs 4
                                         ;; The big-memory machines have 96
                                         ;; logical cores, the others 64.
-- 
2.34.0