diff mbox series

[bug#51198,v2,1/2] build-system/gnu: Add #:local-build? parameter.

Message ID f431dfb3f08a24a6d35bd378bccbf3043beae3db.1638055958.git.leo@famulari.name
State Accepted
Headers show
Series [bug#51198,v2,1/2] build-system/gnu: Add #:local-build? parameter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Nov. 27, 2021, 11:32 p.m. UTC
* guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Add #:local-build?
parameter and pass it to 'build-expression->derivation'.
---
 guix/build-system/gnu.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Simon Tournier Dec. 1, 2021, 3:34 p.m. UTC | #1
Hi Leo,

On Sat, 27 Nov 2021 at 18:32, Leo Famulari <leo@famulari.name> wrote:
> * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Add #:local-build?
> parameter and pass it to 'build-expression->derivation'.

The manual needs to be updated, I guess.  Something there:

<https://guix.gnu.org/manual/devel/en/guix.html#index-gnu_002dbuild_002dsystem>


This gnu-build-system triggers a world rebuild, isn’t it?  Maybe, it
could go to core-updates-frozen now, no? (Now = before merge :-))

Cheers,
simon
Leo Famulari Dec. 1, 2021, 5:50 p.m. UTC | #2
On Wed, Dec 01, 2021 at 04:34:09PM +0100, zimoun wrote:
> On Sat, 27 Nov 2021 at 18:32, Leo Famulari <leo@famulari.name> wrote:
> > * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Add #:local-build?
> > parameter and pass it to 'build-expression->derivation'.
> 
> The manual needs to be updated, I guess.  Something there:
> 
> <https://guix.gnu.org/manual/devel/en/guix.html#index-gnu_002dbuild_002dsystem>

Good idea, I'll send a revised patch series.

> This gnu-build-system triggers a world rebuild, isn’t it?  Maybe, it
> could go to core-updates-frozen now, no? (Now = before merge :-))

As far as I can tell, this does not change any derivations, except of
course if a package definition uses the new #:local-build? option. So it
should be okay for the master branch, if it's a change that we want to
make.
diff mbox series

Patch

diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index 6b481ad45c..fc923f0c5a 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -349,6 +349,7 @@  (define* (gnu-build store name input-drvs
                     (build (nix-system->gnu-triplet system))
                     (imported-modules %gnu-build-system-modules)
                     (modules %default-modules)
+                    (local-build? #f)
                     (substitutable? #t)
                     allowed-references
                     disallowed-references)
@@ -429,6 +430,7 @@  (define guile-for-build
                                 #:inputs input-drvs
                                 #:outputs outputs
                                 #:modules imported-modules
+                                #:local-build? local-build?
                                 #:substitutable? substitutable?
 
                                 #:allowed-references
@@ -504,6 +506,7 @@  (define* (gnu-cross-build store name
                           (build (nix-system->gnu-triplet system))
                           (imported-modules %gnu-build-system-modules)
                           (modules %default-modules)
+                          (local-build? #f)
                           (substitutable? #t)
                           allowed-references
                           disallowed-references)
@@ -595,6 +598,7 @@  (define guile-for-build
                                 #:inputs (append native-drvs target-drvs)
                                 #:outputs outputs
                                 #:modules imported-modules
+                                #:local-build? local-build?
                                 #:substitutable? substitutable?
 
                                 #:allowed-references