diff mbox series

[bug#51957] gnu: xfce-weather-plugin: Fix build by depending on libsoup2.

Message ID EwabuyA7QX05DbWHyHrD2MRVwjkneJVbtUWLvtrsXRE@cp4-web-032.plabs.ch
State Accepted
Headers show
Series [bug#51957] gnu: xfce-weather-plugin: Fix build by depending on libsoup2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Kaelyn Takata Nov. 18, 2021, 9:33 p.m. UTC
* gnu/packages/xfce.scm (xfce-weather-plugin)[inputs]: Depend on
libsoup-minimal-2 as the current version only supports libsoup2.
---
 gnu/packages/xfce.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Kaelyn Takata Nov. 18, 2021, 9:50 p.m. UTC | #1
I forgot to update the subject line before sending the email. This patch is based on core-updates-frozen, fixing a build issue I encountered:

checking pkg-config is at least version 0.9.0... yes
checking for libsoup-2.4 >= 2.42.0... not found
*** The required package libsoup-2.4 was not found on your system.
*** Please install libsoup-2.4 (atleast version 2.42.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.
error: in phase 'configure': uncaught exception:
%exception #<&invoke-error program: "/gnu/store/vx6vfbmmazvfi7vp8xyjn2mcyylvw9gn-bash-minimal-5.1.8/bin/bash" arguments: ("./configure" "CONFIG_SHELL=/gnu/store/vx6vfbmmazvfi7vp8xyjn2mcyylvw9gn-bash-minimal-5.1.8/bin/bash" "SHELL=/gnu/store/vx6vfbmmazvfi7vp8xyjn2mcyylvw9gn-bash-minimal-5.1.8/bin/bash" "--prefix=/gnu/store/sf3l4yvm4hg2h1778kp10hzhmcbg4axq-xfce4-weather-plugin-0.11.0" "--enable-fast-install" "--build=x86_64-unknown-linux-gnu") exit-status: 1 term-signal: #f stop-signal: #f>
phase `configure' failed after 1.3 seconds
Ricardo Wurmus Nov. 21, 2021, 8:05 a.m. UTC | #2
Thank you, I applied the patch to core-updates-frozen.
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c9efdc6efe..91b67d9a0d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -2118,7 +2118,7 @@  (define-public xfce4-weather-plugin
        ("pkg-config" ,pkg-config)))
     (inputs
      `(("gtk+" ,gtk+)
-       ("libsoup" ,libsoup)
+       ("libsoup" ,libsoup-minimal-2)
        ("libxfce4ui" ,libxfce4ui)
        ("libxml2" ,libxml2)
        ("xfce4-panel" ,xfce4-panel)))