diff mbox series

[bug#51339] gnu: MPD: Update to 0.23.2.

Message ID cc08d5a4b98a4437a4f5a948ce3869ade18360a5.1634931719.git.leo@famulari.name
State Accepted
Headers show
Series [bug#51339] gnu: MPD: Update to 0.23.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Oct. 22, 2021, 7:41 p.m. UTC
* gnu/packages/mpd.scm (mpd): Update to 0.23.2.
[arguments]: Use meson-next for meson-build-system.
[inputs]: Add fmt.
[native-inputs]: Add cmake.
---
 gnu/packages/mpd.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès Nov. 14, 2021, 5:28 p.m. UTC | #1
Hi,

Leo Famulari <leo@famulari.name> skribis:

> * gnu/packages/mpd.scm (mpd): Update to 0.23.2.
> [arguments]: Use meson-next for meson-build-system.
> [inputs]: Add fmt.
> [native-inputs]: Add cmake.

You might want to check whether it works with fmt 8.x, which landed just
yesterday, or otherwise change it to ‘fmt-7’.  Otherwise LGTM!  :-)

Ludo’.
Morgan Smith Nov. 14, 2021, 9:04 p.m. UTC | #2
We should add this to the patch:
(properties `((release-monitoring-url . "https://musicpd.org")))

This seems to make guix refresh function properly.

I tested building the patch and that still works but idk if it's
functional.  Also the latest version is now 0.23.4 (Thanks guix
refresh!).


Ludovic Courtès <ludo@gnu.org> writes:

> Hi,
>
> Leo Famulari <leo@famulari.name> skribis:
>
>> * gnu/packages/mpd.scm (mpd): Update to 0.23.2.
>> [arguments]: Use meson-next for meson-build-system.
>> [inputs]: Add fmt.
>> [native-inputs]: Add cmake.
>
> You might want to check whether it works with fmt 8.x, which landed just
> yesterday, or otherwise change it to ‘fmt-7’.  Otherwise LGTM!  :-)
>
> Ludo’.
>
>
Leo Famulari Nov. 15, 2021, 1:55 a.m. UTC | #3
On Sun, Nov 14, 2021 at 04:04:41PM -0500, Morgan Smith wrote:
> 
> We should add this to the patch:
> (properties `((release-monitoring-url . "https://musicpd.org")))
> 
> This seems to make guix refresh function properly.

Thanks for the tip!

> I tested building the patch and that still works but idk if it's
> functional.  Also the latest version is now 0.23.4 (Thanks guix
> refresh!).

Works for me. Pushed as c9b171f46b75665cd475c594f97f663243e21ed1
diff mbox series

Patch

diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index b031525ad4..afcec1183d 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -42,8 +42,10 @@  (define-module (gnu packages mpd)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages avahi)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages build-tools) ;meson-next
   #:use-module (gnu packages boost)
   #:use-module (gnu packages cdrom)
+  #:use-module (gnu packages cmake) ;for MPD
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
@@ -61,6 +63,7 @@  (define-module (gnu packages mpd)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages pretty-print)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages pulseaudio)
@@ -105,7 +108,7 @@  (define-public libmpdclient
 (define-public mpd
   (package
     (name "mpd")
-    (version "0.22.11")
+    (version "0.23.2")
     (source (origin
               (method url-fetch)
               (uri
@@ -114,10 +117,11 @@  (define-public mpd
                               "/mpd-" version ".tar.xz"))
               (sha256
                (base32
-                "1850ii8vnv5l8b561fai4q2mcrnym94mvlrxiy48fvpfm8s7ygql"))))
+                "1pydbbv07jmw5vymrclccldv6w3gz4ch1mv5gjmsxfj6jxl7bv3l"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags '("-Ddocumentation=enabled")))
+     `(#:meson ,meson-next ; Requires Meson >= 0.56.0
+       #:configure-flags '("-Ddocumentation=enabled")))
     (inputs `(("ao" ,ao)
               ("alsa-lib" ,alsa-lib)
               ("avahi" ,avahi)
@@ -125,6 +129,7 @@  (define-public mpd
               ("curl" ,curl)
               ("ffmpeg" ,ffmpeg)
               ("flac" ,flac)
+              ("fmt" ,fmt)
               ("glib" ,glib)
               ("icu4c" ,icu4c)
               ;; The LAME decoder comes from FFmpeg, but is added here so that
@@ -139,7 +144,8 @@  (define-public mpd
               ("pulseaudio" ,pulseaudio)
               ("sqlite" ,sqlite)
               ("zlib" ,zlib)))
-    (native-inputs `(("pkg-config" ,pkg-config)
+    (native-inputs `(("cmake" ,cmake)
+                     ("pkg-config" ,pkg-config)
                      ("python-sphinx" ,python-sphinx)))
     ;; Missing optional inputs:
     ;;   libyajl