diff mbox series

[bug#51587,v2,1/3] gnu: Add python-sgmllib3k.

Message ID BYAPR05MB40236D4705FEE2EFF3E3526BC5949@BYAPR05MB4023.namprd05.prod.outlook.com
State Accepted
Headers show
Series gnu: Add rss2email. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Morgan Smith Nov. 11, 2021, 3:30 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/python-xyz.scm (python-sgmllib3k): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Ludovic Courtès Nov. 12, 2021, 10:59 p.m. UTC | #1
Hi Morgan,

Morgan.J.Smith@outlook.com skribis:

> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/python-xyz.scm (python-sgmllib3k): New variable.

[...]

> * gnu/packages/web.scm (python-feedparser) [propagated-inputs]: Add
> python-sgmllib3k

[...]

> * gnu/packages/mail.scm (rss2email): New variable.

I turned descriptions into full sentences and applied.

Thank you, and thanks Vinicius for reviewing!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 495d7faa87..5fcb513d78 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27786,3 +27786,26 @@  (define-public python-ijson
      "Ijson is an iterative JSON parser with standard Python iterator
 interfaces.")
     (license license:bsd-3)))
+
+(define-public python-sgmllib3k
+  (package
+    (name "python-sgmllib3k")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sgmllib3k" version))
+       (sha256
+        (base32 "1s8jm3dgqabgf8x96931scji679qkhvczlv3qld4qxpsicfgns3q"))))
+    (build-system python-build-system)
+    ;; Requires a test.html input that is not supplied
+    (arguments
+     `(#:tests? #f))
+    (home-page "https://pypi.org/project/sgmllib3k/")
+    ;; Actual homepage seems to be down
+    ;; (home-page "https://hg.hardcoded.net/sgmllib")
+    (synopsis "Python 3 port of sgmllib")
+    (description "A quick, dirty, unmaintained port of sgmllib to Python 3.
+It is used to parse text files formatted in @acronym{SGML,Standard Generalized
+Mark-up Language}.")
+    (license license:bsd-3)))