diff mbox series

[bug#51164] gnu: Add vim-tagbar

Message ID PU1PR01MB21551A5FA87F0D2B4136821B8DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#51164] gnu: Add vim-tagbar | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Oct. 12, 2021, 3:48 p.m. UTC
* gnu/packages/vim.scm (vim-tagbar): New variable.
---
 gnu/packages/vim.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)


base-commit: b9c7bbba38f4fb12d2735f2683a40c035f4e7f5f

Comments

Efraim Flashner Oct. 31, 2021, 1:31 p.m. UTC | #1
Patch pushed. I added a follow-up patch to add the location for Guix's
universal-ctags as a fallback location when searching $PATH for ctags.
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 92189b7094..316db2fcdb 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1069,3 +1069,33 @@  your code every time you make a change.  @code{Vim-slime} is an attempt at
 getting some of these features into Vim.  It works with any REPL and isn't tied
 to Lisp.")
       (license license:expat))))
+
+(define-public vim-tagbar
+  (package
+    (name "vim-tagbar")
+    (version "3.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/preservim/tagbar")
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+         (base32 "1fqfs8msmr6d4kpvxqp14sdjvp5fj52q5w5kz71myzcd4kqzmirp"))))
+    (build-system copy-build-system)
+    (arguments
+      '(#:install-plan
+        '(("autoload" "share/vim/vimfiles/")
+          ("doc" "share/vim/vimfiles/")
+          ("plugin" "share/vim/vimfiles/")
+          ("syntax" "share/vim/vimfiles/"))))
+    (home-page "https://github.com/preservim/tagbar")
+    (synopsis " Vim plugin that displays tags in a window, ordered by scope")
+    (description
+      "Tagbar is a Vim plugin that provides an easy way to browse the tags of
+the current file and get an overview of its structure. It does this by creating
+a sidebar that displays the ctags-generated tags of the current file, ordered
+by their scope. This means that for example methods in C++ are displayed under
+the class they are defined in.")
+    (license license:vim)))