diff mbox series

[bug#51090] gnu: supertuxkart: Update to 1.3.

Message ID 20211007220012.7720-1-ahmed@ikasero.com
State Accepted
Headers show
Series [bug#51090] gnu: supertuxkart: Update to 1.3. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

iKaSeRo Oct. 7, 2021, 10 p.m. UTC
* gnu/packages/games.scm (supertuxkart): Update to 1.3.
[source]: Update snippet, previously bundled glew is no longer needed.
[inputs]: Remove fribidi, glew, mesa.
---
 gnu/packages/games.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)

Comments

Ludovic Courtès Oct. 14, 2021, 5:06 p.m. UTC | #1
Hi!

iKaSeRo <ahmed@ikasero.com> skribis:

> * gnu/packages/games.scm (supertuxkart): Update to 1.3.
> [source]: Update snippet, previously bundled glew is no longer needed.
> [inputs]: Remove fribidi, glew, mesa.

Efraim updated it independently as
27e33695b38ecfe28c9d6b2d35e7e87826611a76, so I’m closing this issue.

Let us know if you think something’s missing!

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4d84dd2bcb..9005a389e2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3909,7 +3909,7 @@  This game is based on the GPL version of the famous game TuxRacer.")
 (define-public supertuxkart
   (package
     (name "supertuxkart")
-    (version "1.2")
+    (version "1.3")
     (source
      (origin
        (method url-fetch)
@@ -3917,7 +3917,7 @@  This game is based on the GPL version of the famous game TuxRacer.")
                            version "/SuperTuxKart-" version "-src.tar.xz"))
        (sha256
         (base32
-         "0dvx56hmy6wdhl7m9dw8zc1n3jqfp05gnxl6zs1rbfdyzl5dybh5"))
+         "1z9z13zarv28h4jrmjna5hr6m9266pm7c2kgiwhqls01k06ypazf"))
        (modules '((guix build utils)))
        (snippet
         ;; Delete bundled library sources
@@ -3925,10 +3925,9 @@  This game is based on the GPL version of the famous game TuxRacer.")
            ;; Supertuxkart uses modified versions of the Irrlicht engine
            ;; and the bullet library.  The developers gave an explanation
            ;; here: http://forum.freegamedev.net/viewtopic.php?f=17&t=3906
-           ;; FIXME: try to unbundle angelscript, libmcpp and libraqm
+           ;; FIXME: try to unbundle angelscript, libmcpp, libsquish and libraqm
            (for-each delete-file-recursively
-                     '("lib/glew"
-                       "lib/wiiuse"
+                     '("lib/wiiuse"
                        "lib/enet"))
            #t))))
     (build-system cmake-build-system)
@@ -3936,7 +3935,6 @@  This game is based on the GPL version of the famous game TuxRacer.")
      `(#:tests? #f ; no check target
        #:configure-flags
        (list "-DUSE_WIIUSE=0"
-             "-DUSE_SYSTEM_GLEW=TRUE"
              "-DUSE_SYSTEM_ENET=TRUE"
              ;; In order to use the system ENet library, IPv6 support (added in
              ;; SuperTuxKart version 1.1) must be disabled.
@@ -3946,13 +3944,10 @@  This game is based on the GPL version of the famous game TuxRacer.")
     (inputs
      `(("curl" ,curl)
        ("freetype" ,freetype)
-       ("fribidi" ,fribidi)
-       ("glew" ,glew)
        ("harfbuzz" ,harfbuzz)
        ("libvorbis" ,libvorbis)
        ("libx11" ,libx11)
        ("libxrandr" ,libxrandr)
-       ("mesa" ,mesa)
        ("openal" ,openal)
        ("sdl2" ,sdl2)
        ("zlib" ,zlib)