diff mbox series

[bug#50740,v2] gnu: Add wmname.

Message ID 20210928201724.14408-1-brown121407@posteo.ro
State Accepted
Headers show
Series [bug#50740,v2] gnu: Add wmname. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Alexandru-Sergiu Marton Sept. 28, 2021, 8:17 p.m. UTC
* gnu/packages/suckless.scm (wmname): New variable.
---

I applied the changes suggested by Sarah and added a copyright line. I left
the license set to license:x11 because I saw that other suckless packages that
seem to have the same license still use license:x11 (such as dwm).

 gnu/packages/suckless.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Sarah Morgensen Sept. 29, 2021, 1:23 a.m. UTC | #1
Hello,

Alexandru-Sergiu Marton <brown121407@posteo.ro> writes:

> * gnu/packages/suckless.scm (wmname): New variable.
> ---
>
> I applied the changes suggested by Sarah and added a copyright line. I left
> the license set to license:x11 because I saw that other suckless packages that
> seem to have the same license still use license:x11 (such as dwm).

Thanks for sending an updated patch.

Regarding licensing...

Just because other people are doing something doesn't mean it's the
right answer :)  But if we don't trust interpreting the license text
ourselves, let's check with a third party source:

It looks like the fsf wiki lists wmname as expat [0].

In fact, I checked a few other suckless packages which we list as x11,
and the fsf wiki also lists them as expat instead: dwm [1], dmenu [2],
ST [3].

So those are incorrect.  I suppose I'll open a bug for that.

[0] https://directory.fsf.org/wiki/Wmname#tab=Details
[1] https://directory.fsf.org/wiki/Dwm#tab=Details
[2] https://directory.fsf.org/wiki/Dmenu#tab=Details
[3] https://directory.fsf.org/wiki/ST#tab=Details

--
Sarah
Ludovic Courtès Oct. 13, 2021, 8:45 a.m. UTC | #2
Hi,

Alexandru-Sergiu Marton <brown121407@posteo.ro> skribis:

> * gnu/packages/suckless.scm (wmname): New variable.

I changed the license to ‘expat’ as Sarah rightfully suggested and
applied it.

Thank you, and thanks Sarah for the careful review!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index b24eced379..4ca353ad51 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -488,6 +489,36 @@  few minutes.")
     (home-page "https://tools.suckless.org/sent")
     (license license:x11)))
 
+(define-public wmname
+  (package
+    (name "wmname")
+    (version "0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://dl.suckless.org/tools/wmname-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "1i82ilhbk36hspc2j0fbpg27wjj7xnvzpv1ppgf6fccina4d36jm"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no tests
+       #:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "PREFIX=" %output))
+       #:phases                         ; no tests
+       (modify-phases %standard-phases
+         (delete 'configure))))         ; no configure script
+    (inputs
+     `(("libx11" ,libx11)))
+    (home-page "https://tools.suckless.org/x/wmname/")
+    (synopsis "Print or set the window manager name")
+    (description "@command{wmname} prints/sets the window manager name
+property of the root window similar to how @command{hostname} behaves.  It is
+useful for fixing problems with JDK versions and other broken programs
+assuming a reparenting window manager for instance.")
+    (license license:x11)))
+
 (define-public xbattmon
   (package
     (name "xbattmon")