diff mbox series

[bug#51039] gnu: python-gitpython: Update to 3.1.20.

Message ID 20211005151957.19756-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#51039] gnu: python-gitpython: Update to 3.1.20. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 5, 2021, 3:19 p.m. UTC
* gnu/packages/version-control.scm (python-gitpython): Update to 3.1.20.
---
 gnu/packages/version-control.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Arun Isaac Oct. 9, 2021, 2:40 p.m. UTC | #1
Hi jgart,

There seems to be a newer release 3.1.24 of python-gitpython. Can we
upgrade to that instead?

Thanks!
Arun
jgart Oct. 10, 2021, 6:29 a.m. UTC | #2
Here is the update that you requested.

all best,

jgart
Arun Isaac Oct. 16, 2021, 10:19 a.m. UTC | #3
Hi jgart,

Thanks for the updated patch! I have pushed this patch to master with
the following changes.

> * gnu/packages/version-control.scm (python-gitpython): Update to 3.1.24.
>
> [propagated-inputs]: Add python-typing-extensions.

I removed the blank line above before [propagated-inputs], added a
copyright header for you, removed the #t return from the custom
embed-git-reference phase, and mentioned the removal in the commit
message.

>      (arguments
>       `(#:tests? #f ;XXX: Tests can only be run within the GitPython
>       repository.

If you have the time and are interested, you could also try getting the
tests working for this package, and send a patch with me on Cc. I'll be
happy to review it. Judging from the comment, it seems like switching
from PyPI to the GitHub source might be the solution.

Thanks!
Arun
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index ead33ad10e..201cacbf6b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1157,13 +1157,13 @@  allowing to handle large objects with a small memory footprint.")
 (define-public python-gitpython
   (package
     (name "python-gitpython")
-    (version "3.1.0")
+    (version "3.1.20")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "GitPython" version))
               (sha256
                (base32
-                "1jzllsy9lwc9yibccgv7h9naxisazx2n3zmpy21c8n5xhysw69p4"))))
+                "06b5cdvrh3lx6jvzd325q0lvgfp3cq2dzkxhhx9sc0q740m0f3nz"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f ;XXX: Tests can only be run within the GitPython repository.