diff mbox series

[bug#51042,1/2] gnu: Add catgirl.

Message ID 20211005233755.25862-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#51042,1/2] gnu: Add catgirl. | expand

Commit Message

jgart Oct. 5, 2021, 11:37 p.m. UTC
* gnu/packages/irc.scm (catgirl): New variable.
---
 gnu/packages/irc.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

Comments

Liliana Marie Prikler Oct. 6, 2021, 3:10 p.m. UTC | #1
Am Dienstag, den 05.10.2021, 19:37 -0400 schrieb jgart:
> * gnu/packages/irc.scm (catgirl): New variable.
Reindented and pushed.

Thanks
jgart Oct. 6, 2021, 5:51 p.m. UTC | #2
On Wed, 06 Oct 2021 17:10:17 +0200 Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
> Am Dienstag, den 05.10.2021, 19:37 -0400 schrieb jgart:
> > * gnu/packages/irc.scm (catgirl): New variable.
> Reindented and pushed.

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 9258d1ee32..3c2dae1284 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -47,6 +47,7 @@ 
   #:use-module (gnu packages base)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages code)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
@@ -325,6 +326,49 @@  for the IRCv3 protocol.")
      "ircII is a terminal based IRC and ICB client for UNIX systems.")
     (license license:bsd-3)))
 
+(define-public catgirl
+  (package
+    (name "catgirl")
+    (version "1.9a")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://git.causal.agency/catgirl/snapshot/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0pci8crcgm33zb58y7ky2aydzyqsirj8ri8ik1zdlz6npadbjj9h"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no tests
+       #:make-flags (list (string-append "PREFIX=" %output)
+                          ,(string-append "CC=" (cc-for-target)))))
+    (native-inputs
+      `(("universal-ctags" ,universal-ctags)
+        ("pkg-config" ,pkg-config)))
+    (inputs
+      `(("libressl" ,libressl)
+        ("ncurses" ,ncurses)))
+    (home-page "https://git.causal.agency/catgirl")
+    (synopsis "TLS-only terminal IRC client")
+    (description
+"@command{catgirl} is a TLS-only terminal IRC client.
+
+Notable features include:
+@itemize
+@item Tab complete: most recently seen or mentioned nicks are completed first.
+  Commas are inserted between multiple nicks.
+@item Prompt: the prompt clearly shows whether input will be interpreted as a
+command or sent as a message.
+@item Split scroll: keeps the latest messages in view while scrolling.
+@item URL detection: recent URLs from a particular user or matching a
+substring can be opened or copied.
+@item Nick coloring: color generation based on usernames remains stable across
+nick changes.  Mentions of users in messages are colored.
+@item Topic diffing: the modified portion of a channel topic change is
+highlighted.
+@end itemize")
+    (license license:gpl3+)))
+
 (define-public ii
   (package
     (name "ii")