diff mbox series

[bug#50967,12/14] gnu: home-services: Update %service-type-path.

Message ID 20211002163834.29583-12-go.wigust@gmail.com
State Accepted
Headers show
Series [bug#50967,01/14] tests: Add tests for guix home cli. | expand

Commit Message

Oleg Pykhalov Oct. 2, 2021, 4:38 p.m. UTC
* gnu/home-services.scm
(%service-type-path): Search home services in "gnu/services".
* gnu/home-services.scm: Update documentation string.
---
 gnu/home-services.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Oct. 4, 2021, 2:01 p.m. UTC | #1
Oleg Pykhalov <go.wigust@gmail.com> skribis:

> * gnu/home-services.scm
> (%service-type-path): Search home services in "gnu/services".
> * gnu/home-services.scm: Update documentation string.
> ---
>  gnu/home-services.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/home-services.scm b/gnu/home-services.scm
> index 9f1e986616..a244a15511 100644
> --- a/gnu/home-services.scm
> +++ b/gnu/home-services.scm
> @@ -512,10 +512,10 @@ environment, and its configuration file, when available.")))
>  
>  (define %service-type-path
>    ;; Search path for service types.
> -  (make-parameter `((,%guix-home-root-directory . "gnu/home-services"))))
> +  (make-parameter `((,%guix-home-root-directory . "gnu/home/services"))))
>  

I think it would make more sense to squeeze patches 2 to 12 (inclusive)
as a single patch.  That way, both the previous and the next commit
would be in working state, which may not be the case when we rename
things one by one (for example, renamed service modules won’t be
discovered until the hunk above is applied.)

Otherwise LGTM, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/home-services.scm b/gnu/home-services.scm
index 9f1e986616..a244a15511 100644
--- a/gnu/home-services.scm
+++ b/gnu/home-services.scm
@@ -512,10 +512,10 @@  environment, and its configuration file, when available.")))
 
 (define %service-type-path
   ;; Search path for service types.
-  (make-parameter `((,%guix-home-root-directory . "gnu/home-services"))))
+  (make-parameter `((,%guix-home-root-directory . "gnu/home/services"))))
 
 (define (all-home-service-modules)
-  "Return the default set of home-service modules."
+  "Return the default set of `home service' modules."
   (cons (resolve-interface '(gnu home-services))
         (all-modules (%service-type-path)
                      #:warn warn-about-load-error)))