diff mbox series

[bug#50547,core-updates-frozen] gnu: gobby: Update to 0.6.0.

Message ID 20210912123047.145477-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#50547,core-updates-frozen] gnu: gobby: Update to 0.6.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Sept. 12, 2021, 12:30 p.m. UTC
This fixes a build failure due to our libinfinite being too recent for
gobby 0.5.0.

* gnu/packages/gobby.scm (gobby): Update to 0.6.0.
  [build-system]: Change to glib-or-gtk-build-system which helps to find
  glib-compile-schemas.
  [native-inputs]: Add itstool.
  [inputs]: Replace gtkmm-2 with gtkmm and gtksourceview-2 with
  gtksourceview-3.
---
 gnu/packages/gobby.scm | 15 +++++++++------
 1 file changed, 9 insertions(+), 6 deletions(-)

Comments

Efraim Flashner Sept. 12, 2021, 1:48 p.m. UTC | #1
Thanks. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/gobby.scm b/gnu/packages/gobby.scm
index 931b35bc52..aeec3d6de9 100644
--- a/gnu/packages/gobby.scm
+++ b/gnu/packages/gobby.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2017, 2019 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24,6 +25,7 @@ 
   #:use-module (guix download)
   #:use-module (guix utils)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages glib)
@@ -143,7 +145,7 @@  connect to a server running the old 0.4 protocol.")
 (define-public gobby
   (package
     (name "gobby")
-    (version "0.5.0")
+    (version "0.6.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://releases.0x539.de/gobby/gobby-"
@@ -151,16 +153,17 @@  connect to a server running the old 0.4 protocol.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "165x0r668ma5blziisvbr8qig3jw9hf7i6w8r7wwvz3wsac3bswc"))))
-    (build-system gnu-build-system)
+                "1p2wbnchxy2wdzk19p7bxfpbq5zawa0l500na57jp8jgk3qz7czx"))))
+    (build-system glib-or-gtk-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)))
+       ("intltool" ,intltool)
+       ("itstool" ,itstool)))
     (inputs
      `(("gnutls" ,gnutls)
        ("gsasl" ,gsasl)
-       ("gtkmm-2" ,gtkmm-2)
-       ("gtksourceview-2" ,gtksourceview-2)
+       ("gtkmm" ,gtkmm)
+       ("gtksourceview" ,gtksourceview-3)
        ("libinfinity" ,libinfinity)
        ("libxml++-2" ,libxml++-2)))
     (arguments