diff mbox series

[bug#50434,core-updates-frozen] gnu: librime: Fix build with GCC 10.

Message ID 20210906174244.7686-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#50434,core-updates-frozen] gnu: librime: Fix build with GCC 10. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Sept. 6, 2021, 5:42 p.m. UTC
* gnu/packages/ibus.scm (librime)[source]: Add a patch that adds missing
  includes.
* gnu/packages/patches/librime-add-missing-includes.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/ibus.scm                         |  2 ++
 .../librime-add-missing-includes.patch        | 28 +++++++++++++++++++
 3 files changed, 31 insertions(+)
 create mode 100644 gnu/packages/patches/librime-add-missing-includes.patch

Comments

Leo Famulari Sept. 7, 2021, 6:13 p.m. UTC | #1
On Mon, Sep 06, 2021 at 05:42:44PM +0000, Felix Gruber wrote:
> * gnu/packages/ibus.scm (librime)[source]: Add a patch that adds missing
>   includes.
> * gnu/packages/patches/librime-add-missing-includes.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add it.

Thanks! I tweaked the patch name and description and the commit title
and pushed as d5a1206beb06678a2cb3ffcc25b687bb9fbfec74
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index eab40771b5..88869a8186 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1285,6 +1285,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/libblockdev-glib-compat.patch		\
   %D%/packages/patches/libffi-3.3-powerpc-fixes.patch		\
   %D%/packages/patches/libffi-float128-powerpc64le.patch	\
+  %D%/packages/patches/librime-add-missing-includes.patch	\
   %D%/packages/patches/libvirt-add-install-prefix.patch	\
   %D%/packages/patches/libziparchive-add-includes.patch		\
   %D%/packages/patches/localed-xorg-keyboard.patch		\
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 4cec104bab..ac4efccf85 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2018, 2019, 2020, 2021 Peng Mei Yu <pengmeiyu@riseup.net>
 ;;; Copyright © 2020 kanichos <kanichos@yandex.ru>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -367,6 +368,7 @@  Japanese language input in most graphical applications.")
        (sha256
         (base32
          "0pqk0i3zcii3fx5laj9qzbgd58jvq6wn31j76w4zix2i4b1lqcqv"))
+       (patches (search-patches "librime-add-missing-includes.patch"))
        (modules '((guix build utils)))
        (snippet
         '(begin
diff --git a/gnu/packages/patches/librime-add-missing-includes.patch b/gnu/packages/patches/librime-add-missing-includes.patch
new file mode 100644
index 0000000000..a74c67c751
--- /dev/null
+++ b/gnu/packages/patches/librime-add-missing-includes.patch
@@ -0,0 +1,28 @@ 
+From: Felix Gruber <felgru@posteo.net>
+Date: Mon, 6 Sep 2021 19:38:17 +0200
+Subject: [PATCH] Add missing <cmath> includes
+
+diff --git a/src/rime/gear/script_translator.cc b/src/rime/gear/script_translator.cc
+index 4a45f05..515c8db 100644
+--- a/src/rime/gear/script_translator.cc
++++ b/src/rime/gear/script_translator.cc
+@@ -7,6 +7,7 @@
+ // 2011-07-10 GONG Chen <chen.sst@gmail.com>
+ //
+ #include <algorithm>
++#include <cmath>
+ #include <stack>
+ #include <boost/algorithm/string/join.hpp>
+ #include <boost/range/adaptor/reversed.hpp>
+diff --git a/src/rime/gear/table_translator.cc b/src/rime/gear/table_translator.cc
+index 162ac02..dbea76a 100644
+--- a/src/rime/gear/table_translator.cc
++++ b/src/rime/gear/table_translator.cc
+@@ -4,6 +4,7 @@
+ //
+ // 2011-07-10 GONG Chen <chen.sst@gmail.com>
+ //
++#include <cmath>
+ #include <boost/algorithm/string.hpp>
+ #include <boost/range/adaptor/reversed.hpp>
+ #include <utf8.h>