diff mbox series

[bug#50393] gnu: Add wlsunset.

Message ID 20210905071150.50526fd4@riseup.net
State Accepted
Headers show
Series [bug#50393] gnu: Add wlsunset. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Csepp Sept. 5, 2021, 5:11 a.m. UTC
* gnu/packages/xdisorg.scm (wlsunset): New variable.
---
 gnu/packages/xdisorg.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Nicolas Goaziou Sept. 6, 2021, 9:08 a.m. UTC | #1
Hello,

raingloom <raingloom@riseup.net> writes:

> +(define-public wlsunset

Thank you. Some nits follow.

> +  (package
> +    (name "wlsunset")
> +    (version "0.2.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://git.sr.ht/~kennylevinsen/wlsunset/")
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "0hhsddh3rs066rbsjksr8kcwg8lvglbvs67dq0r5wx5c1xcwb51w"))))
> +    (build-system meson-build-system)
> +    (inputs
> +     `(("wayland-protocols" ,wayland-protocols)
> +       ("wayland" ,wayland)))

Could you order inputs alphabetically?

> +    (native-inputs
> +     `(("pkg-config" ,pkg-config)))
> +    (synopsis "Day/night gamma adjustments for Wayland compositors")
> +    (home-page "https://sr.ht/~kennylevinsen/wlsunset/")
> +    (description
> +     "Day/night gamma adjustments for Wayland compositors supporting
> +wlr-gamma-control-unstable-v1.  Also known as a blue light filter or
> night +light.")

Could you use complete sentences for the description? I suggest using
markup: @samp{wlr-gamma-control-unstable-v1}.

Regards,
Nicolas Goaziou Sept. 15, 2021, 7:28 p.m. UTC | #2
Hello,

raingloom <raingloom@riseup.net> writes:

> Thanks for the feedback, here is the fixed patch.

Thank you. I tweaked the description and applied it.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 006b1c11ac..396a704d80 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3015,3 +3015,31 @@  System.  This includes such features as
MouseKeys, AccessX, StickyKeys, BounceKeys, and SlowKeys.  It includes
a graphical program to help with MouseKeys-acceleration management.")
     (license license:bsd-3)))
+
+(define-public wlsunset
+  (package
+    (name "wlsunset")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~kennylevinsen/wlsunset/")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0hhsddh3rs066rbsjksr8kcwg8lvglbvs67dq0r5wx5c1xcwb51w"))))
+    (build-system meson-build-system)
+    (inputs
+     `(("wayland-protocols" ,wayland-protocols)
+       ("wayland" ,wayland)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (synopsis "Day/night gamma adjustments for Wayland compositors")
+    (home-page "https://sr.ht/~kennylevinsen/wlsunset/")
+    (description
+     "Day/night gamma adjustments for Wayland compositors supporting
+wlr-gamma-control-unstable-v1.  Also known as a blue light filter or
night +light.")
+    (license license:expat)))