diff mbox series

[bug#50375,v2] gnu: Add mlterm.

Message ID 20210905113102.9467-1-ahmed@ikasero.com
State Accepted
Headers show
Series [bug#50375,v2] gnu: Add mlterm. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

iKaSeRo Sept. 5, 2021, 11:31 a.m. UTC
* gnu/packages/terminals.scm (mlterm): New variable.
---
Xinglu Chen <public@yoctocell.xyz> writes:

>> * gnu/packages/terminals.scm (mlterm): New variable.
>> ---
>>  gnu/packages/terminals.scm | 40 ++++++++++++++++++++++++++++++++++++++
>>  1 file changed, 40 insertions(+)
>>
>> diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
>> index 1cdf0e1831..037504ee4f 100644
>> --- a/gnu/packages/terminals.scm
>> +++ b/gnu/packages/terminals.scm
>> @@ -25,6 +25,7 @@
>>  ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
>>  ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
>>  ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
>> +;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
>>  ;;;
>>  ;;; This file is part of GNU Guix.
>>  ;;;
>> @@ -66,6 +67,7 @@
>>    #:use-module (gnu packages docbook)
>>    #:use-module (gnu packages fontutils)
>>    #:use-module (gnu packages freedesktop)
>> +  #:use-module (gnu packages fribidi)
>>    #:use-module (gnu packages gettext)
>>    #:use-module (gnu packages ghostscript)
>>    #:use-module (gnu packages gl)
>> @@ -1458,3 +1460,41 @@ ephemeral serial ports.  It features automatic port detection, port enumeration,
>>  support for non-standard baud rates, the ability to wait for ports to appear,
>>  and the ability to read and write via stdin and stdout.")
>>      (license license:expat)))
>> +
>> +(define-public mlterm
>> +  (package
>> +    (name "mlterm")
>> +    (version "3.9.1")
>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (string-append "mirror://sourceforge/mlterm/01release/mlterm-"
>> +                           version "/mlterm-" version ".tar.gz"))
>> +       (sha256
>> +        (base32
>> +         "03fnynwv7d1aicwk2rp31sgncv5m65agvygqvsgn59v9di40gnnb"))))
>> +    (build-system gnu-build-system)
>> +    (arguments `(#:tests? #f
>
> What’s the reason for disabling tests; there should be a comment with a
> short explanation.
>
Because there are no tests, Now I added a comment thanks!
> Nit: This is usually on its own line
>
>   (arguments
>    `(#:tests? #f
>      #:configure-flags
>      ...))
>
Didn't know that, fixed
>> +                 #:configure-flags
>> +                 (list (string-append "--prefix=" (assoc-ref %outputs "out"))
>> +                       "--disable-static"
>> +                       "--enable-optimize-redrawing"
>> +                       "--with-imagelib=gdk-pixbuf")))
>> +    (native-inputs
>> +     `(("gettext" ,gettext-minimal)
>> +       ("pkg-config" ,pkg-config)))
>> +    (inputs
>> +     `(("cairo" ,cairo)
>> +       ("fontconfig" ,fontconfig)
>> +       ("freetype" ,freetype)
>> +       ("fribidi" ,fribidi)
>> +       ("gdk-pixbuf" ,gdk-pixbuf)
>> +       ("gtk+" ,gtk+)
>> +       ("libx11" ,libx11)
>> +       ("libxext" ,libxext)
>> +       ("libxft" ,libxft)))
>> +    (home-page "http://mlterm.sourceforge.net/")
>> +    (synopsis "Multi Lingual TERMinal emulator")
>> +    (description "mlterm is a multi-lingual terminal emulator which supports
>> +various character sets and encodings in the world.")
>> +    (license license:bsd-3)))
>> -- 
>> 2.33.0
>
> The package builds fine, and the rest LGTM!
Thanks for the review!

 gnu/packages/terminals.scm | 41 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Xinglu Chen Sept. 5, 2021, 6:43 p.m. UTC | #1
On Sun, Sep 05 2021, iKaSeRo wrote:

> * gnu/packages/terminals.scm (mlterm): New variable.
> ---
> Xinglu Chen <public@yoctocell.xyz> writes:
>
>>> * gnu/packages/terminals.scm (mlterm): New variable.
>>> ---
>>>  gnu/packages/terminals.scm | 40 ++++++++++++++++++++++++++++++++++++++
>>>  1 file changed, 40 insertions(+)
>>>
>>> diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
>>> index 1cdf0e1831..037504ee4f 100644
>>> --- a/gnu/packages/terminals.scm
>>> +++ b/gnu/packages/terminals.scm
>>> @@ -25,6 +25,7 @@
>>>  ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
>>>  ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
>>>  ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
>>> +;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
>>>  ;;;
>>>  ;;; This file is part of GNU Guix.
>>>  ;;;
>>> @@ -66,6 +67,7 @@
>>>    #:use-module (gnu packages docbook)
>>>    #:use-module (gnu packages fontutils)
>>>    #:use-module (gnu packages freedesktop)
>>> +  #:use-module (gnu packages fribidi)
>>>    #:use-module (gnu packages gettext)
>>>    #:use-module (gnu packages ghostscript)
>>>    #:use-module (gnu packages gl)
>>> @@ -1458,3 +1460,41 @@ ephemeral serial ports.  It features automatic port detection, port enumeration,
>>>  support for non-standard baud rates, the ability to wait for ports to appear,
>>>  and the ability to read and write via stdin and stdout.")
>>>      (license license:expat)))
>>> +
>>> +(define-public mlterm
>>> +  (package
>>> +    (name "mlterm")
>>> +    (version "3.9.1")
>>> +    (source
>>> +     (origin
>>> +       (method url-fetch)
>>> +       (uri (string-append "mirror://sourceforge/mlterm/01release/mlterm-"
>>> +                           version "/mlterm-" version ".tar.gz"))
>>> +       (sha256
>>> +        (base32
>>> +         "03fnynwv7d1aicwk2rp31sgncv5m65agvygqvsgn59v9di40gnnb"))))
>>> +    (build-system gnu-build-system)
>>> +    (arguments `(#:tests? #f
>>
>> What’s the reason for disabling tests; there should be a comment with a
>> short explanation.
>>
> Because there are no tests, Now I added a comment thanks!
>> Nit: This is usually on its own line
>>
>>   (arguments
>>    `(#:tests? #f
>>      #:configure-flags
>>      ...))
>>
> Didn't know that, fixed
>>> +                 #:configure-flags
>>> +                 (list (string-append "--prefix=" (assoc-ref %outputs "out"))
>>> +                       "--disable-static"
>>> +                       "--enable-optimize-redrawing"
>>> +                       "--with-imagelib=gdk-pixbuf")))
>>> +    (native-inputs
>>> +     `(("gettext" ,gettext-minimal)
>>> +       ("pkg-config" ,pkg-config)))
>>> +    (inputs
>>> +     `(("cairo" ,cairo)
>>> +       ("fontconfig" ,fontconfig)
>>> +       ("freetype" ,freetype)
>>> +       ("fribidi" ,fribidi)
>>> +       ("gdk-pixbuf" ,gdk-pixbuf)
>>> +       ("gtk+" ,gtk+)
>>> +       ("libx11" ,libx11)
>>> +       ("libxext" ,libxext)
>>> +       ("libxft" ,libxft)))
>>> +    (home-page "http://mlterm.sourceforge.net/")
>>> +    (synopsis "Multi Lingual TERMinal emulator")
>>> +    (description "mlterm is a multi-lingual terminal emulator which supports
>>> +various character sets and encodings in the world.")
>>> +    (license license:bsd-3)))
>>> -- 
>>> 2.33.0
>>
>> The package builds fine, and the rest LGTM!
> Thanks for the review!

You are welcome!  The updated patch looks good, but I don’t have commit
access.
Tobias Geerinckx-Rice Sept. 5, 2021, 10:18 p.m. UTC | #2
iKaSeRo,

iKaSeRo 写道:
> * gnu/packages/terminals.scm (mlterm): New variable.

Pushed as commit 53ccbc175570c4fd16b499670d37b36328d30f94.  I 
moved the package somewhere vaguely alphabetical (terminals.scm 
isn't) and expanded the description slightly based on the man 
page.

Thanks!

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 1cdf0e1831..4c39b41f0a 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
+;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -66,6 +67,7 @@ 
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages fribidi)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
@@ -1458,3 +1460,42 @@  ephemeral serial ports.  It features automatic port detection, port enumeration,
 support for non-standard baud rates, the ability to wait for ports to appear,
 and the ability to read and write via stdin and stdout.")
     (license license:expat)))
+
+(define-public mlterm
+  (package
+    (name "mlterm")
+    (version "3.9.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/mlterm/01release/mlterm-"
+                           version "/mlterm-" version ".tar.gz"))
+       (sha256
+        (base32
+         "03fnynwv7d1aicwk2rp31sgncv5m65agvygqvsgn59v9di40gnnb"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:configure-flags
+       (list (string-append "--prefix=" (assoc-ref %outputs "out"))
+             "--disable-static"
+             "--enable-optimize-redrawing"
+             "--with-imagelib=gdk-pixbuf")))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)
+       ("fontconfig" ,fontconfig)
+       ("freetype" ,freetype)
+       ("fribidi" ,fribidi)
+       ("gdk-pixbuf" ,gdk-pixbuf)
+       ("gtk+" ,gtk+)
+       ("libx11" ,libx11)
+       ("libxext" ,libxext)
+       ("libxft" ,libxft)))
+    (home-page "http://mlterm.sourceforge.net/")
+    (synopsis "Multi Lingual TERMinal emulator")
+    (description "mlterm is a multi-lingual terminal emulator which supports
+various character sets and encodings in the world.")
+    (license license:bsd-3)))