diff mbox series

[bug#50368,9/9] gnu: Add rust-tiny-http-0.8.

Message ID 16QDEht90be1FeTK5-0tpYmUtdkhCiAEWhCUE7vaGboZY_hE3GtkzZBc0ZTgBpyf0vETIuENyQ90MB1Ml8kQizQW7saHac16fn44JHDUaAc=@protonmail.com
State Accepted
Headers show
Series [bug#50368,1/9] gnu: rust-multipart-0.17: Fix inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 4, 2021, 9:06 a.m. UTC
* gnu/packages/crates-io.scm (rust-tiny-http-0.8): New variable.

--
2.32.0

Comments

Xinglu Chen Sept. 4, 2021, 7:32 p.m. UTC | #1
On Sat, Sep 04 2021, phodina via Guix-patches via wrote:

> * gnu/packages/crates-io.scm (rust-tiny-http-0.8): New variable.

‘rust-tiney-http-0.6’ should be mentioned in the ChangeLog.

> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 9c331c7140..68a3f79353 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -49233,8 +49233,43 @@ closures after a delay or at a given timestamp.")
>  manipulation in Rust.")
>      (license license:expat)))
>
> +(define-public rust-tiny-http-0.8
> +  (package
> +    (name "rust-tiny-http")
> +    (version "0.8.2")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "tiny-http" version))
> +       (file-name
> +        (string-append name "-" version ".tar.gz"))

Nit: No need for a newline.

> +       (sha256
> +        (base32
> +         "0fcdwpb2ghk671qjjrk6048hs3yp7f681hxpr68gamk00181prcw"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +     `(#:cargo-inputs
> +       (("rust-ascii" ,rust-ascii-1)
> +        ("rust-chrono" ,rust-chrono-0.4)
> +        ("rust-chunked-transfer"
> +         ,rust-chunked-transfer-1)
> +        ("rust-log" ,rust-log-0.4)
> +        ("rust-openssl" ,rust-openssl-0.10)
> +        ("rust-url" ,rust-url-2))
> +       #:cargo-development-inputs
> +       (("rust-fdlimit" ,rust-fdlimit-0.1)
> +        ("rust-rustc-serialize"
> +         ,rust-rustc-serialize-0.3)
> +        ("rust-sha1" ,rust-sha1-0.6))))
> +    (home-page
> +     "https://github.com/tiny-http/tiny-http")

Likewise.

> +    (synopsis "Low level HTTP server library")
> +    (description "This package provides a low level HTTP server library.")
> +    (license (list license:expat license:asl2.0))))
> +
>  (define-public rust-tiny-http-0.6
>    (package
> +    (inherit rust-tiny-http-0.8)
>      (name "rust-tiny-http")
>      (version "0.6.2")
>      (source
> @@ -49244,7 +49279,6 @@ manipulation in Rust.")
>         (file-name (string-append name "-" version ".tar.gz"))
>         (sha256
>          (base32 "0la95daknfh8g951ddb2zdz6av2459rncp6h9dh02pf98h5glq8n"))))
> -    (build-system cargo-build-system)
>      (arguments
>       `(#:skip-build? #t
>         #:cargo-inputs
> @@ -49253,11 +49287,7 @@ manipulation in Rust.")
>          ("rust-chunked-transfer" ,rust-chunked-transfer-0.3)
>          ("rust-log" ,rust-log-0.4)
>          ("rust-openssl" ,rust-openssl-0.10)
> -        ("rust-url" ,rust-url-1))))
> -    (home-page "https://github.com/tiny-http/tiny-http")
> -    (synopsis "Low level HTTP server library")
> -    (description "This package provides a low level HTTP server library.")
> -    (license license:asl2.0)))
> +        ("rust-url" ,rust-url-1))))))
>
>  (define-public rust-tiny-keccak-2
>    (package
> --
> 2.32.0
phodina Sept. 5, 2021, 1:10 p.m. UTC | #2
Hi Xinglu,

thanks for the hints. I'll fix them and sent new patches.

FIY the newlines are generated by the script in etc/indent-code.el. Is there some config to disable these newlines?

Petr
Xinglu Chen Sept. 5, 2021, 1:48 p.m. UTC | #3
On Sun, Sep 05 2021, phodina via Guix-patches via wrote:

> Hi Xinglu,
>
> thanks for the hints. I'll fix them and sent new patches.

You are welcome!  :-)

> FIY the newlines are generated by the script in etc/indent-code.el. Is
> there some config to disable these newlines?

Are you sure about that?  I don’t use etc/indent-code.el, but it seems
to only untabify (replace tabs with spaces) and indent the package
definitions.  Its probably the importer itself that outputs those
newlines; I think that has to do with how the Guile pretty-printer
works.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9c331c7140..68a3f79353 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49233,8 +49233,43 @@  closures after a delay or at a given timestamp.")
 manipulation in Rust.")
     (license license:expat)))

+(define-public rust-tiny-http-0.8
+  (package
+    (name "rust-tiny-http")
+    (version "0.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "tiny-http" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0fcdwpb2ghk671qjjrk6048hs3yp7f681hxpr68gamk00181prcw"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-ascii" ,rust-ascii-1)
+        ("rust-chrono" ,rust-chrono-0.4)
+        ("rust-chunked-transfer"
+         ,rust-chunked-transfer-1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-openssl" ,rust-openssl-0.10)
+        ("rust-url" ,rust-url-2))
+       #:cargo-development-inputs
+       (("rust-fdlimit" ,rust-fdlimit-0.1)
+        ("rust-rustc-serialize"
+         ,rust-rustc-serialize-0.3)
+        ("rust-sha1" ,rust-sha1-0.6))))
+    (home-page
+     "https://github.com/tiny-http/tiny-http")
+    (synopsis "Low level HTTP server library")
+    (description "This package provides a low level HTTP server library.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-tiny-http-0.6
   (package
+    (inherit rust-tiny-http-0.8)
     (name "rust-tiny-http")
     (version "0.6.2")
     (source
@@ -49244,7 +49279,6 @@  manipulation in Rust.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "0la95daknfh8g951ddb2zdz6av2459rncp6h9dh02pf98h5glq8n"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
@@ -49253,11 +49287,7 @@  manipulation in Rust.")
         ("rust-chunked-transfer" ,rust-chunked-transfer-0.3)
         ("rust-log" ,rust-log-0.4)
         ("rust-openssl" ,rust-openssl-0.10)
-        ("rust-url" ,rust-url-1))))
-    (home-page "https://github.com/tiny-http/tiny-http")
-    (synopsis "Low level HTTP server library")
-    (description "This package provides a low level HTTP server library.")
-    (license license:asl2.0)))
+        ("rust-url" ,rust-url-1))))))

 (define-public rust-tiny-keccak-2
   (package