diff mbox series

[bug#49533,v2] gnu: Add omins-lv2.

Message ID 20210724194117.8372-1-t_w_@freenet.de
State New
Headers show
Series [bug#49533,v2] gnu: Add omins-lv2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thorsten Wilms July 24, 2021, 7:41 p.m. UTC
* gnu/packages/audio.scm (omins-lv2): New variable.
---
Thanks to Sarah for having a look and noticing the superfluous --prefix.

 gnu/packages/audio.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Ludovic Courtès July 29, 2021, 7:53 p.m. UTC | #1
Hi Thorsten,

Thorsten Wilms <t_w_@freenet.de> skribis:

> * gnu/packages/audio.scm (omins-lv2): New variable.

It LGTM, modulo minor issues:

> +(define-public omins-lv2
> +  (package
> +   (name "omins-lv2")

Please consider passing it through ./etc/indent-code.el:

  https://guix.gnu.org/manual/en/html_node/Formatting-Code.html

> +   ;; No release despite being perfectly usable. 0.0.0 seems to be the only
> +   ;; version the author ever specified:
> +   (version "0.0.0")
> +   (source
> +    (origin
> +     (method git-fetch)
> +     (uri
> +      (git-reference
> +       (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
> +       (commit "058f341053067b69a84d4081107fda5058290ff9")))

Please check out
<https://guix.gnu.org/manual/en/html_node/Version-Numbers.html> on how
to compute version numbers in such cases.

> +   (native-search-paths
> +    (list (search-path-specification
> +           (variable "LV2_PATH")
> +           (files '("lib/lv2")))))

I’m surprised this is here (in the plugin) rather than in the package
that loads this plugin.  There are other LV2 plugins doing that though.
Ricardo, WDYT?

> +   (license (list license:gpl2+ license:gpl2+))))

(license license:gpl2+) should be enough.  :-)

Could you send an updated patch?

Thank you, and thanks, Sarah!

Ludo’.
Ludovic Courtès Sept. 1, 2021, 9:29 p.m. UTC | #2
Hi Thorsten,

Did you have a chance to look into this?

Thanks,
Ludo’.

Ludovic Courtès <ludo@gnu.org> skribis:

> Hi Thorsten,
>
> Thorsten Wilms <t_w_@freenet.de> skribis:
>
>> * gnu/packages/audio.scm (omins-lv2): New variable.
>
> It LGTM, modulo minor issues:
>
>> +(define-public omins-lv2
>> +  (package
>> +   (name "omins-lv2")
>
> Please consider passing it through ./etc/indent-code.el:
>
>   https://guix.gnu.org/manual/en/html_node/Formatting-Code.html
>
>> +   ;; No release despite being perfectly usable. 0.0.0 seems to be the only
>> +   ;; version the author ever specified:
>> +   (version "0.0.0")
>> +   (source
>> +    (origin
>> +     (method git-fetch)
>> +     (uri
>> +      (git-reference
>> +       (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
>> +       (commit "058f341053067b69a84d4081107fda5058290ff9")))
>
> Please check out
> <https://guix.gnu.org/manual/en/html_node/Version-Numbers.html> on how
> to compute version numbers in such cases.
>
>> +   (native-search-paths
>> +    (list (search-path-specification
>> +           (variable "LV2_PATH")
>> +           (files '("lib/lv2")))))
>
> I’m surprised this is here (in the plugin) rather than in the package
> that loads this plugin.  There are other LV2 plugins doing that though.
> Ricardo, WDYT?
>
>> +   (license (list license:gpl2+ license:gpl2+))))
>
> (license license:gpl2+) should be enough.  :-)
>
> Could you send an updated patch?
>
> Thank you, and thanks, Sarah!
>
> Ludo’.
Ricardo Wurmus Sept. 2, 2021, 7:56 a.m. UTC | #3
Ludovic Courtès <ludo@gnu.org> writes:

>> +   (native-search-paths
>> +    (list (search-path-specification
>> +           (variable "LV2_PATH")
>> +           (files '("lib/lv2")))))
>
> I’m surprised this is here (in the plugin) rather than in the 
> package
> that loads this plugin.  There are other LV2 plugins doing that 
> though.
> Ricardo, WDYT?

Yes, this looks wrong.

Plugins don’t need to set LV2_PATH; only hosts (such as Ardour, 
jalv, and others) do.  This must have been an early mistake that 
has been copied for other plugins.  None of the LV2 hosts that we 
offer set LV2_PATH.
Thorsten Wilms Sept. 2, 2021, 8:03 a.m. UTC | #4
On Wed, 01 Sep 2021 23:29:18 +0200
Ludovic Courtès <ludo@gnu.org> wrote:

> Did you have a chance to look into this?

Hi Ludovic, I missed to notice your earlier email. Thanks for it and
this reminder!


> > Please consider passing it through ./etc/indent-code.el:
> >
> >   https://guix.gnu.org/manual/en/html_node/Formatting-Code.html

I assumed Emacs would do the right thing as is. My guix-installed Emacs
does not offer a guix-devel-mode. There’s also no ./etc/indent-code.el
on this foreign distro.


> > Please check out
> > <https://guix.gnu.org/manual/en/html_node/Version-Numbers.html> on
> > how to compute version numbers in such cases.

Done. Assuming the very last example shows the pattern to use, I
suspect that there are a lot of packages that should, but do not use
it. At least in audio.scm.


> >> +   (native-search-paths
> >> +    (list (search-path-specification
> >> +           (variable "LV2_PATH")
> >> +           (files '("lib/lv2")))))
> >
> > I’m surprised this is here (in the plugin) rather than in the
> > package that loads this plugin.  There are other LV2 plugins doing
> > that though. Ricardo, WDYT?

I mean to recall that this was necessary for the first lv2 package I
wrote, but from then on, I may have been cargo-culting. Since my
lilv and sord are still broken, no lv2-host will run. So I can’t even
test this now.


> >> +   (license (list license:gpl2+ license:gpl2+))))
> >
> > (license license:gpl2+) should be enough.  :-)

Sheesh, I did it again!

New patch version follows in separate email.


Thanks!
Ludovic Courtès Sept. 2, 2021, 9:45 a.m. UTC | #5
Hi!

Thorsten Wilms <t_w_@freenet.de> skribis:

> On Wed, 01 Sep 2021 23:29:18 +0200
> Ludovic Courtès <ludo@gnu.org> wrote:

[...]

>> > Please consider passing it through ./etc/indent-code.el:
>> >
>> >   https://guix.gnu.org/manual/en/html_node/Formatting-Code.html
>
> I assumed Emacs would do the right thing as is. My guix-installed Emacs
> does not offer a guix-devel-mode. There’s also no ./etc/indent-code.el
> on this foreign distro.

‘guix-devel-mode’ is part of the ‘emacs-guix’ package (aka. guix.el).
(If you have that, you don’t need indent-code.el, which is itself in the
Guix source tree.)

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3939d4bc7e..b5471c9d3d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5410,3 +5410,36 @@  device.  There is support for mono and/or stereo and 8 or 16 bit samples.")
      "MDA-LV2 is an LV2 port of the MDA plugins.  It includes effects and a few
 instrument plugins.")
     (license license:gpl3+)))
+
+(define-public omins-lv2
+  (package
+   (name "omins-lv2")
+   ;; No release despite being perfectly usable. 0.0.0 seems to be the only
+   ;; version the author ever specified:
+   (version "0.0.0")
+   (source
+    (origin
+     (method git-fetch)
+     (uri
+      (git-reference
+       (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+       (commit "058f341053067b69a84d4081107fda5058290ff9")))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32 "01hnx4hhbz3ap3bw15s42q4q1mw1mhdjwygq4550wvjfg6k4ga8w"))))
+   (build-system waf-build-system)
+   (arguments
+    `(#:tests? #f)) ; There are no tests.
+   (inputs
+    `(("lv2" ,lv2)))
+   (native-inputs
+    `(("pkg-config" ,pkg-config)))
+   (native-search-paths
+    (list (search-path-specification
+           (variable "LV2_PATH")
+           (files '("lib/lv2")))))
+   (home-page "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+   (synopsis "LV2 audio plugins for modular synthesis")
+   (description
+    "Omins-lv2 is a small collection of LV2 audio plugins for modular synthesis.")
+   (license (list license:gpl2+ license:gpl2+))))