diff mbox series

[bug#46885] gnu: artanis: Update to 0.5.

Message ID 20210303011502.15822-1-lle-bout@zaclys.net
State Accepted
Headers show
Series [bug#46885] gnu: artanis: Update to 0.5. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Léo Le Bouter March 3, 2021, 1:15 a.m. UTC
* gnu/packages/guile-xyz.scm (artanis): Update to 0.5.
[inputs]: Remove guile-2.2; add guile-3.0-latest and nspr.
[propagated-inputs]: Remove guile-json-1, guile2.2-readline, and guile2.2-redis; add guile-json-3, guile-readline, and guile-redis.
---
 gnu/packages/guile-xyz.scm | 30 ++++++++++++++++++------------
 1 file changed, 18 insertions(+), 12 deletions(-)

Comments

Ludovic Courtès March 17, 2021, 9:31 p.m. UTC | #1
Hi,

Léo Le Bouter <lle-bout@zaclys.net> skribis:

> * gnu/packages/guile-xyz.scm (artanis): Update to 0.5.
> [inputs]: Remove guile-2.2; add guile-3.0-latest and nspr.
> [propagated-inputs]: Remove guile-json-1, guile2.2-readline, and guile2.2-redis; add guile-json-3, guile-readline, and guile-redis.


[...]

>      (inputs
> -     `(("guile" ,guile-2.2)
> -       ("nss" ,nss)))
> +     `(("guile" ,guile-3.0-latest)

Just ‘guile-3.0’ (unless there’s a good reason to use
‘guile-3.0-latest’?).

Otherwise LGTM!

>         (let* ((out (assoc-ref %outputs "out"))
> -              (scm (string-append out "/share/guile/site/2.2"))
> -              (go  (string-append out "/lib/guile/2.2/site-ccache")))
> +              (scm (string-append out "/share/guile/site/3.0"))
> +              (go  (string-append out "/lib/guile/3.0/site-ccache")))
>           ;; Don't use (%site-dir) for site paths.
>           (list (string-append "MOD_PATH=" scm)
>                 (string-append "MOD_COMPILED_PATH=" go)))
> @@ -193,7 +194,7 @@
>                 (("\\(%site-dir\\)")
>                  (string-append "\""
>                                 (assoc-ref outputs "out")
> -                               "/share/guile/site/2.2\"")))))
> +                               "/share/guile/site/3.0\"")))))

[...]

> -                    (scm (string-append out "/share/guile/site/2.2"))
> -                    (go  (string-append out "/lib/guile/2.2/site-ccache")))
> +                    (scm (string-append out "/share/guile/site/3.0"))
> +                    (go  (string-append out "/lib/guile/3.0/site-ccache")))

Perhaps for a separate patch, but it would be best to avoid hardcoding
the Guile effective version number.

The other packages show how to accomplish this.  Ideally, Makefile.am &
co. would refer to $(GUILE_EFFECTIVE_VERSION).  When that’s not the case
(yet), we can patch them to do so, as is done for several packages in
guile-xyz.scm.

Thanks,
Ludo’.
Ludovic Courtès Aug. 30, 2021, 10:08 a.m. UTC | #2
Hello Arun,

Arun Isaac <arunisaac@systemreboot.net> skribis:

> I incorporated your suggestions and finished this patchset. I'll push to
> master if it looks good.
>
> Thanks,
> Arun
>
> Arun Isaac (1):
>   gnu: artanis: Remove hard-coded guile effective version.
>
> Léo Le Bouter (1):
>   gnu: artanis: Update to 0.5.

LGTM, thanks!

Ludo’.
Arun Isaac Sept. 1, 2021, 12:01 p.m. UTC | #3
> LGTM, thanks!

Pushed to master!
jgart Sept. 1, 2021, 12:38 p.m. UTC | #4
Thanks for closing this one and upgrading artanis. This was on my Guix TODO list.

 _________________________________________ 
/ 3B1D 7F19 E36B B60C 0F5B 2CA9 A52A A2B4 \
\ 77B6 DD35                               /
 ----------------------------------------- 
        \   ^__^
         \  (oo)\_______
            (__)\       )\/\
                ||----w |
                ||     ||
Arun Isaac Sept. 2, 2021, 5:52 a.m. UTC | #5
> Thanks for closing this one and upgrading artanis. This was on my Guix
> TODO list.

Happy to help! :-)
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 45b3a82d00..9b3e0b04ec 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -122,14 +122,14 @@ 
 (define-public artanis
   (package
     (name "artanis")
-    (version "0.4.1")
+    (version "0.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/artanis/artanis-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0nnmdfx5xwcc3kck64var7msz7g3qk817d7bv9l159nkmic0v9w4"))
+                "1vk1kp2xhz35xa5n27cxlq9c88wk6qm7fqaac8rb0pb6k9pvsv7v"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -161,16 +161,17 @@ 
                   #t))))
     (build-system gnu-build-system)
     (inputs
-     `(("guile" ,guile-2.2)
-       ("nss" ,nss)))
+     `(("guile" ,guile-3.0-latest)
+       ("nss" ,nss)
+       ("nspr" ,nspr)))
     ;; FIXME the bundled csv contains one more exported procedure
     ;; (sxml->csv-string) than guile-csv. The author is maintainer of both
     ;; projects.
     ;; TODO: Add guile-dbi and guile-dbd optional dependencies.
     (propagated-inputs
-     `(("guile-json" ,guile-json-1) ; This is already using guile-2.2.
-       ("guile-readline" ,guile2.2-readline)
-       ("guile-redis" ,guile2.2-redis)))
+     `(("guile-json" ,guile-json-3)
+       ("guile-readline" ,guile-readline)
+       ("guile-redis" ,guile-redis)))
     (native-inputs
      `(("bash"       ,bash)         ;for the `source' builtin
        ("pkgconfig"  ,pkg-config)
@@ -179,8 +180,8 @@ 
      '(#:make-flags
        ;; TODO: The documentation must be built with the `docs' target.
        (let* ((out (assoc-ref %outputs "out"))
-              (scm (string-append out "/share/guile/site/2.2"))
-              (go  (string-append out "/lib/guile/2.2/site-ccache")))
+              (scm (string-append out "/share/guile/site/3.0"))
+              (go  (string-append out "/lib/guile/3.0/site-ccache")))
          ;; Don't use (%site-dir) for site paths.
          (list (string-append "MOD_PATH=" scm)
                (string-append "MOD_COMPILED_PATH=" go)))
@@ -193,7 +194,7 @@ 
                (("\\(%site-dir\\)")
                 (string-append "\""
                                (assoc-ref outputs "out")
-                               "/share/guile/site/2.2\"")))))
+                               "/share/guile/site/3.0\"")))))
          (add-after 'unpack 'patch-reference-to-libnss
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "artanis/security/nss.scm"
@@ -201,6 +202,11 @@ 
                 (string-append
                  "ffi-binding \""
                  (assoc-ref inputs "nss") "/lib/nss/libnss3.so"
+                 "\""))
+               (("ffi-binding \"libssl3\"")
+                (string-append
+                 "ffi-binding \""
+                 (assoc-ref inputs "nss") "/lib/nss/libssl3.so"
                  "\"")))
              #t))
          (add-before 'install 'substitute-root-dir
@@ -216,8 +222,8 @@ 
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin"))
-                    (scm (string-append out "/share/guile/site/2.2"))
-                    (go  (string-append out "/lib/guile/2.2/site-ccache")))
+                    (scm (string-append out "/share/guile/site/3.0"))
+                    (go  (string-append out "/lib/guile/3.0/site-ccache")))
                (wrap-program (string-append bin "/art")
                  `("GUILE_LOAD_PATH" ":" prefix
                    (,scm ,(getenv "GUILE_LOAD_PATH")))