diff mbox series

[bug#50065,v2] gnu: Add setroot.

Message ID 20210831200657.28627-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#50065,v2] gnu: Add setroot. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Brice Waegeneire Aug. 31, 2021, 8:06 p.m. UTC
* gnu/packages/xorg.scm (setroot): New variable.
---
 gnu/packages/xorg.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Thank you for the review Mathieu.  I fixed the three issues you pointed out.

Comments

Mathieu Othacehe Sept. 1, 2021, 6:53 a.m. UTC | #1
Hey Brice,

> * gnu/packages/xorg.scm (setroot): New variable.

Looks fine, feel free to proceed :).

Mathieu
Brice Waegeneire Sept. 4, 2021, 7:32 a.m. UTC | #2
Mathieu Othacehe <othacehe@gnu.org> writes:

> Looks fine, feel free to proceed :).

Pushed as 2226d5b9590840f6fdc0d5c03b14c9d050435c4e. Thank you for the review
Mathieu.
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6f9633985e..cae0fb3f73 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6925,3 +6925,38 @@  an existing user-specified one, writes a cookie to it, and then starts the
 the server and cleaning up before returning the exit status of the command.")
     (license (list license:x11                    ; the script
                    license:gpl2+))))              ; the man page
+
+(define-public setroot
+  (package
+    (name "setroot")
+    (version "2.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ttzhou/setroot")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0w95828v0splk7bj5kfacp4pq6wxpyamvyjmahyvn5hc3ycq21mq"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+             "PREFIX="
+             "xinerama=1")
+       #:tests? #f                       ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (inputs
+     `(("imlib2" ,imlib2)
+       ("libx11" ,libx11)
+       ("libxinerama" ,libxinerama)))
+    (home-page "https://github.com/ttzhou/setroot")
+    (synopsis "Simple X background setter inspired by imlibsetroot and feh")
+    (description "Setroot is a lightweight X background setter with feh's
+syntax without its image viewing capabilities.  It supports multiple monitors
+and can restore previously set wallpapers and options.")
+    (license license:gpl3+)))