diff mbox series

[bug#49703] gnu: Add rust-rot8

Message ID JXhdJVbh6eBC7z3b4DRh2h2DMYc_8Jhksy1n9ewZoQhvAWXb7cadH5kzmIYMfdF0uIXzrEDYXS7xD-u2DcDNIfZ9B6nmdy0wYqhx2jDgsgw=@protonmail.com
State New
Headers show
Series [bug#49703] gnu: Add rust-rot8 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 23, 2021, 3:27 a.m. UTC
---
--
2.31.1

Comments

Xinglu Chen July 24, 2021, 1:19 p.m. UTC | #1
On Fri, Jul 23 2021, phodina via Guix-patches via wrote:

> ---

Please write a proper commit message in the GNU ChangeLog format; you
can see the commit log for examples, or read the manual.

  <https://www.gnu.org/prep/standards/html_node/Change-Logs.html>

> +(define-public rust-rot8-0.1
> +  (package
> +    (name "rust-rot8")
> +    (version "0.1.3")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (crate-uri "rot8" version))
> +        (file-name
> +          (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "15mhszk9qy2q49dpab4p0d9d4aph61yshaxjf02mhdx07n9qpnmh"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +      `(#:cargo-inputs
> +        (("rust-clap" ,rust-clap-2)
> +         ("rust-glob" ,rust-glob-0.3)
> +         ("rust-regex" ,rust-regex-1)
> +         ("rust-serde" ,rust-serde-1)
> +         ("rust-serde-json" ,rust-serde-json-1))))
> +    (home-page "https://github.com/efernau/rot8")
> +    (synopsis
> +      "A screen rotation daemon")

Avoid articles like “A” or “An” in the synopsis.

> +    (description
> +      "Automatic rotation for modern Linux screen and input device. Compatible

The description should consist of full sentences, and there should be
two spaces after periods.  See the “16.4.4 Synopses and Descriptions” in
the manual for more details.  Make sure to run ‘guix lint’ to catch
common mistakes like these.  :)

Otherwise, LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a6a383156d..07b1de05df 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Antero Mejr <antero@kodmin.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -37525,6 +37526,35 @@  text-buffer for applications such as text editors.  Ropey is fast, robust, and
 can handle huge texts and memory-incoherent edits with ease.")
     (license license:expat)))

+(define-public rust-rot8-0.1
+  (package
+    (name "rust-rot8")
+    (version "0.1.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "rot8" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "15mhszk9qy2q49dpab4p0d9d4aph61yshaxjf02mhdx07n9qpnmh"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-clap" ,rust-clap-2)
+         ("rust-glob" ,rust-glob-0.3)
+         ("rust-regex" ,rust-regex-1)
+         ("rust-serde" ,rust-serde-1)
+         ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/efernau/rot8")
+    (synopsis
+      "A screen rotation daemon")
+    (description
+      "Automatic rotation for modern Linux screen and input device. Compatible
+with wayland and X11. Uses built-in accelerometer with configurable threshold.")
+    (license license:expat)))
+
 (define-public rust-route-recognizer-0.2
   (package
     (name "rust-route-recognizer")