diff mbox series

[bug#49455] gnu: add libgpiod

Message ID 20210707075638.18941-1-i.gankevich@spbu.ru
State Accepted
Headers show
Series [bug#49455] gnu: add libgpiod | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ivan Gankevich July 7, 2021, 7:56 a.m. UTC
---
 gnu/packages/linux.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Ludovic Courtès July 20, 2021, 8:25 p.m. UTC | #1
Hi,

Ivan Gankevich <i.gankevich@spbu.ru> skribis:

> +(define-public libgpiod
> +  (package
> +    (name "libgpiod")
> +    (version "1.6.3")

I tweaked the synopsis and description, added a copyright line for you,
adjusted the commit log as per our conventions, and committed.

Thanks!

Ludo’.
Ivan Gankevich July 21, 2021, 9:59 a.m. UTC | #2
>I tweaked the synopsis and description, added a copyright line for you,
>adjusted the commit log as per our conventions, and committed.

Thank you, Ludo.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index da3c8755f6..9c83f1969d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8248,3 +8248,39 @@  Availability and Serviceability} reports from Linux kernel trace events.
 These trace events are logged in @file{/sys/kernel/debug/tracing} and reported
 through standard log mechanisms like syslog.")
     (license license:gpl2)))
+
+(define-public libgpiod
+  (package
+    (name "libgpiod")
+    (version "1.6.3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git")
+            (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256 (base32 "0rv8a11hx3pc6sdw6nfc6k35hkp2clb3v53n1381cvip8fzhbsad"))))
+    (build-system gnu-build-system)
+    (arguments
+      `(#:configure-flags
+        '("--enable-tools=yes"
+          "--enable-bindings-cxx"
+          "--enable-bindings-python")))
+    (native-inputs
+      `(("automake" ,automake)
+        ("autoconf" ,autoconf)
+        ("libtool" ,libtool)
+        ("autoconf-archive" ,autoconf-archive)
+        ("pkg-config" ,pkg-config)
+        ("python" ,python-3)))
+    (synopsis "C library and tools for interacting with the linux GPIO character device")
+    (description "C library with C++/Python bindings and command line tools
+for interacting with GPIO devices that avoids the usage of older system-wide
+/sys interface.")
+    (home-page "https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/")
+    (license (list license:lgpl2.1+ ;; libgpiod
+                   license:gpl2+    ;; gpio-tools
+                   license:lgpl3+   ;; C++ bindings
+                   ))))